PDA

View Full Version : opengl/openinventor/rh7.3



mghere
12-05-2003, 05:54 PM
New to linux, and having previously used rh9 where a lot of the rpms i need were included during the install process, i am rapidly spiraling into confusion when trying to install openinventor on a system running rh7.3 (and that uses NVIDIA graphics drivers).

I am writing this group as openGL seems to be a requirement for this install, but it seems odd...

I thought mesa was included in the rh install (XFree86 standard for rh7.3, yes?), that the NVIDIA drivers only overwrote certain libraries...

However, when trying to install openinventor2.1.5-73 rpms, the system says:
[@localhost openInventor]# rpm -ivh openinventor-2.1.5-7.3.i386.rpm
error: failed dependencies:
OpenGL is needed by openinventor-2.1.5-7.3
libstdc++.so.2.10 is needed by openinventor-2.1.5-7.3

Note, when trying the other rpms, openinventor2.1.5-10 from sgi, it balks saying:
libc.so.6(GLIBC_2.3) is needed by sgi-OpenInventor-clients-2.1.5-10
libgcc_s.so.1 is needed by sgi-OpenInventor-clients-2.1.5-10
libgcc_s.so.1(GCC_3.0) is needed by sgi-OpenInventor-clients-2.1.5-10
libstdc++.so.5 is needed by sgi-OpenInventor-clients-2.1.5-10
libstdc++.so.5(CXXABI_1.2) is needed by sgi-OpenInventor-clients-2.1.5-10
libstdc++.so.5(GLIBCPP_3.2) is needed by sgi-OpenInventor-clients-2.1.5-10

(libs included, i believe, with rh9)

I am doubly confused because the last time i looked, opengl was (sgi) proprietary...

I can't seem to find any other versions (of OI, so am sorta stuck...mebbe it will be more clear in the morning ;], but i am just not sure what to add/do at this point.

anybody know/understand what i mean/need to do so i don't kill what i have?

Thanks in advance :]

D1G1T4LL
12-06-2003, 10:17 PM
I'm not sure if its the full solution to your problem, but it looks the same like when I did't get my Redbook examples compiled. I guess it will work if U update your GCC compiler, which u can find on the next website : ftp://ftp.gnu.org/pub/gnu/ in the GCC subfolder. I hope that will do the job for u, good luck, and greetz for Holland.

mghere
12-07-2003, 07:57 AM
thanks for your reply! http://www.opengl.org/discussion_boards/ubb/wink.gif

What you suggest is reasonable, and ordinarily, tho i managed to dissolve a previous install mucking with those libraries (argh!), This time I can't update any libraries (i have rh9 installed on another disc, with the updated libs but need rh7.3 libs) -- the application i need to run needs the old ones ;(, hence the probs!

I did find, however, a note from a geowall install, which uses same rh7.3 libraries (they had trouble with 2.1.5-7.3 also - tis the NVIDIA drivers most likely); it might be that openinventer2.1.5-8, rather than 7.3 or 10, both which i have tried, might work. Note indicates possible need for reinstallation of mesa, then loading inventor, then doing uninstall-reinstall of NVIDIA drivers ;P , but will see ... just have to find/will hunt more for 2.1.3-8 and try/cross fingers i guess http://www.opengl.org/discussion_boards/ubb/wink.gif!

thanks much again -- good to get a response, as well -- lots going in Holland, I know!!!

D1G1T4LL
12-08-2003, 12:13 AM
Ah, now I see.

Cant u get the OpenInventor source and try to build it yourself. I'm used to building most of it all myself (slackware). and usually It works. If u get the source, u can add to the copilerline
for example :
gcc -o openinvent openinvent.c -L/folder/otherfolder/folderwithrh73libs

I recently found out that with /L u can specify your library folder. Maybe this will help, otherwise, I'm sure u will get it to work, somehow, just because it must work.