PDA

View Full Version : NVidia Quadro FX Go700 under Linux



KenRussell
08-28-2003, 03:13 PM
I'm trying to install NVidia's Linux driver on a Dell Precision M60 with Quadro FX Go700 graphics running Red Hat 9. The symptom is that when X is started, the screen goes gray and apparently stops refreshing the LCD, so that the screen gets brighter and brighter over several seconds' time until you switch back to one of the consoles, at which point the black background is now gray but the white text is still white. I can usually get the screen to reset itself if I put the VESA XF86Config back in place and restart the X server; this occasionally causes the screen to stay permanently gray, requiring a reboot.

I went through the following troubleshooting steps:

- Checked the XFree86 logs and /var/log/messages. Found a warning that agpgart had failed to load because the AGP chip set was unsupported. Added a line for agpgart in /etc/modules.conf to specify agp_try_unsupported=1 to this module. This got rid of the warning but the driver still doesn't work. There was another warning about a character major device not being found, but this warning's been there since before I tried installing the NVidia drivers so I don't think it's related. /etc/modules.conf does have an NVidia-related alias in it and there are no warnings about not finding that module.

- Read the README and looked at the sample XF86Config file to see if there was anything obviously wrong. I've successfully installed NVidia's drivers on a few other machines and didn't see any of the usual pitfalls of forgetting to remove incompatible modules.

Thanks for any suggestions.

KenRussell
09-02-2003, 03:13 PM
FYI, I've heard from NVidia that this is a known bug with the 44.96 driver. The 43.63 driver works fine on the M60, and can be downloaded at ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4363/ .

jerryyyyy
10-05-2003, 04:01 PM
I am in the same boat with a new m60. Has this problem with the 44.96 ever been resolved? I guess not since that seems to be the current driver out there. It looks to me like 43.63 does not do a number of hardware functions that I need and would like to get the newer driver to work.