PDA

View Full Version : Am I using OpenGL?



Kage
01-28-2002, 07:02 PM
Is there some documentation I could read to explain to me how the OpenGL interface works? Im confused because I downloaded the winex package but It wouldnt install because It said I needed OpenGL. Well I thought linux used OpenGL for everything. My Nvidia drivers loaded just fine and Im able to play UT and Q3 as well. But it occurred to me that if OpenGL isnt installed on my system then what API are my nvidia drivers using?

nukem
01-30-2002, 08:36 PM
i got the same problem. i think its that linux didnt come w/ the headers for OpenGL. im on mandrake wat r u on? the win header(from VC++ cygwin) dont work on linux. i cannt find any were to dl the headers.

AIM: nukem996

jackz
01-31-2002, 12:08 AM
Originally posted by nukem:
i got the same problem. i think its that linux didnt come w/ the headers for OpenGL. im on mandrake wat r u on? the win header(from VC++ cygwin) dont work on linux. i cannt find any were to dl the headers.

AIM: nukem996

Opengl headers are in mesa-devel and mesa-demos-devel packages in mandrake if I remember right.

urpmf gl.h should show what package to install for it.

usually headers are in -devel packages.

Kage
01-31-2002, 11:44 PM
Im running RH7.2 I found out I needed mesa but the problem now is I went to rpmfind.net and got the opengl rpm. It wouldnt install because it needed opengl-core. Opengl-core wouldnt install because it needed mesa, but mesa wont install because it needs opengl. So how do I get out of this loop?

[This message has been edited by Kage (edited 02-01-2002).]