PDA

View Full Version : libGLcore.so.1



01-16-2004, 04:09 AM
just a quick ? Is libGLcore.so.1 file specific to nVidia, or is that file available while using lets say an ATI video card. I have an application that says it is not found and I am using an ATI Fire card. Should I buy an nVidia chip card? OpenGL is installed on SuSe Linux 8.2

Thanks a bunch. Have a great day!

Jim

01-16-2004, 11:18 AM
libGL* are installed when you install the NVidia or ATI drivers (or Mesa).

01-20-2004, 05:05 AM
Proggy thanks for you answer, but I already have ATI drivers loaded and still no libGLcore. I have installed xfglrx.rpm and km_xfiregl1.rpm
lsmod shows xfglrx loaded.
fglrxinfo shows:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Fire GL X1 Pentium 4 (SSE2) (FireGL)
OpenGL version string: 1.3 (X4.3.0-2.9.13)

mesa is installed as is Xfree86 glx driver 4.3.0-19

any ideas would be appreciated.

idr
01-20-2004, 06:37 AM
The only libGLcore that I'm aware of is libGLcore.a that's used in the X-server. Can you provide some more details about your system and the error you're seeing?

01-21-2004, 03:10 AM
I seem to have opengl working by creating a link named libGLcore.so.1 to libGL.so.1 What is the difference between these two libraries? Are they the same? I have a Dell Precision 650 work station, ATI Fire x1 , 4gb ram, dual xeon, 140 gb LSI raid array, running SuSe Linux 8.2, kernel 2.4.20-64GB-SMP. Video driver is xfglrx.rpm & km_xfiregl1.rpm Results of fglrxinfo is:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Fire GL X1 Pentium 4 (SSE2) (FireGL)
OpenGL version string: 1.3 (X4.3.0-2.9.13)

application error I was getting is:

error while loading shared libraries: libglcore.so.1 cannot open shared object file. File or directory not found.

dorbie
01-21-2004, 12:49 PM
Sounds like you've done something heinous.

Just link dynamically to the gl libs. Not to glcore, that's implementation specific, and don't go around making symbolic links like this on your system unless you're sure you're doing the right thing, because it'll look for the dynamic libs you specified at link time searching the ld_librarypath on any system you deploy on.

Link as per the standard ABI here:
http://oss.sgi.com/projects/ogl-sample/ABI/#3

If you still have problems then you have a driver/configuration problem, not a development problem. Reinstall drivers following the package instructions carefully.

01-22-2004, 10:31 AM
Yes I have done something heinous, but nothing wants to install pesky libGLcore.so.1 Not X, mesa, ATI fglrx drivers. I reloaded Linux from scratch, reloaded ATI drivers from SuSe and everything works fine. glxgears @ 4100 fps, and other 3d apps. But I have a specialized CAD app that keeps asking for libGLcore.so.1 .! I'm ready to buy a nVidia card because it libGLcore.so.1 comes with thier drivers.


Thanks for your help

dorbie
01-22-2004, 12:22 PM
Did you compile this app?

If so then just do as I already instructed and don't link it to glcore, it's pretty simple really. Link to gl.

If you didn't compile it then it's really the developers problem and you're suffering from their mistake. Ask the developer not to link directly to glcore.

[This message has been edited by dorbie (edited 01-22-2004).]