PDA

View Full Version : How to install openGL under Linux Debian



NighTiger
09-16-2003, 06:26 AM
Hi everybody,
I would like beginnig to study this libraries, but when I trie to run the program I received this text

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

I've just installed the GLX kenerl source and drivers

ii nvidia-glx 1.0.4496-2.1 NVIDIA binary XFree86 4.x driver
ii nvidia-kernel- 1.0.4496-2.1 NVIDIA binary kernel module source

And when X run I received this

(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not
found)

How can I make to correct this errors and, finally, can run the opengl program?
bye

FermatSpiral
09-16-2003, 12:54 PM
Have you followed the instructions at /usr/share/doc/nvidia-glx/README.Debian?

In particular the part about modifying /etc/X11/XF86Config-4

NighTiger
09-16-2003, 01:10 PM
Originally posted by FermatSpiral:
Have you followed the instructions at /usr/share/doc/nvidia-glx/README.Debian?

In particular the part about modifying /etc/X11/XF86Config-4




I haven't /usr/share/doc/nvidia-glx/README.Debian

jmg
09-16-2003, 02:57 PM
Are there other .deb's from nvidia's site that contain the docs you need?

zen
09-16-2003, 03:22 PM
I really doubt you managed to get an X server with no glx extension on debian so make sure that the line:
Load "glx"
appears in the "Module" section. It's probably just not configured to load the extension you need.

NighTiger
09-17-2003, 10:21 PM
Originally posted by zen:
I really doubt you managed to get an X server with no glx extension on debian so make sure that the line:
Load "glx"
appears in the "Module" section. It's probably just not configured to load the extension you need.

I've modified the X file config with Load "glx" but I received this text

(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not
found)

zen
09-18-2003, 01:59 AM
Have you compiled/installed the nvidia driver? Just downloading the packages isn't enough as they're just installers. You have to run the installer (not sure of the name, 'nvidia-installer' I think) and it will download and setup the drivers for X and the kernel.

NighTiger
09-18-2003, 02:18 AM
Originally posted by zen:
Have you compiled/installed the nvidia driver? Just downloading the packages isn't enough as they're just installers. You have to run the installer (not sure of the name, 'nvidia-installer' I think) and it will download and setup the drivers for X and the kernel.


no I haven't 'nvidia-installer'...
but How I compile the package???

NighTiger
09-18-2003, 04:39 AM
okkey....

I've found tha package under /usr/src

I've installed it "tar xvzf package.tgz"

Now I've readed the Readme.Debian, but I don't understand what I must do for compile the modules and install it...

zen
09-18-2003, 06:25 AM
Well I'm not sure as I don't have the debian packages(I have the ones that nvidia ships), but there should be some installation instructions(usually file named INSTALL) in the package or maybe /usr/share/docs.
Do dpkg -L xxx where xxx are the debian package names (nvidia-glx, nvidia-kernel) to see what files they contain and where they are. Look for documentation. Sorry I can't help out more. I would install the debian packages myself but that means that I'll have to re download the drivers I have allready downloaded from nvidia(~8MB) so I'll do it when the drivers get updated.

NighTiger
09-18-2003, 02:29 PM
Originally posted by zen:
Well I'm not sure as I don't have the debian packages(I have the ones that nvidia ships), but there should be some installation instructions(usually file named INSTALL) in the package or maybe /usr/share/docs.
Do dpkg -L xxx where xxx are the debian package names (nvidia-glx, nvidia-kernel) to see what files they contain and where they are. Look for documentation. Sorry I can't help out more. I would install the debian packages myself but that means that I'll have to re download the drivers I have allready downloaded from nvidia(~8MB) so I'll do it when the drivers get updated.

I've readed the documentation, I've tried much than one once... but nothing...

isn't there a debian user that use the opengl libraries????

help me please

pkaler
09-18-2003, 03:09 PM
I wouldn't use the .deb package. Run the sh file that nvidia provides and follow the directions on how to edit your X86Config.

09-18-2003, 03:43 PM
Install the binary XFree86 4.x driver:

# apt-get install nvidia-glx

Additionally, for the development files:

# apt-get install nvidia-glx-dev

Install the nvidia binary kernel module source:

# apt-get install nvidia-kernel-source

For building information of the "nvidia-kernel" .deb package (ie. the nvidia kernel binary module) read:

/usr/share/doc/nvidia-kernel-source/README.Debian

In the XF86Config file replace:

Driver "nv"

... with:

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

NighTiger
09-23-2003, 09:18 AM
When I give "make" I receive this

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1

but I don't understand what it want

zen
09-23-2003, 09:51 AM
Well what it means is that the kernel was compiled with a gcc of different version than the one you're using to compile the driver. So you'll have to recompile your kernel with your current gcc.

09-24-2003, 04:43 AM
To find out the version of gcc used to compile your kernel:

$ cat /proc/version

Install the same version of gcc used to compile your kernel. Set the CC variable to the name of this gcc and try compiling the kernel module, eg.

# export CC=gcc-3.2
# make

NighTiger
09-25-2003, 02:00 AM
Linux version 2.4.20 (root@silent) (gcc version 3.3.1 20030626 (Debian prerelease)) #33 SMP Sun Aug 31 02:41:50 CEST 2003

export CC=gcc-3.3
make

receive always the same text

09-25-2003, 06:40 AM
Try compiling the module with this:

# export CC=gcc-3.3
# export IGNORE_CC_MISMATCH=yes
# make

BTW, what is the output of the following command?

$ gcc-3.3 -v 2>&1 | tail -n 1 | cut -d ' ' -f 3

NighTiger
09-25-2003, 12:14 PM
Originally posted by xuzzy:
Try compiling the module with this:

# export CC=gcc-3.3
# export IGNORE_CC_MISMATCH=yes
# make



Well well... this's correct


Originally posted by xuzzy:
BTW, what is the output of the following command?

$ gcc-3.3 -v 2>&1 | tail -n 1 | cut -d ' ' -f 3

gcc version 3.3.2 20030908 (Debian prerelease)

now, what I can do?

NighTiger
09-26-2003, 12:05 PM
Originally posted by NighTiger:

now, what I can do?[/B]

Okkey I've setuped all... but after the compilation of NeHe tutorial with SDL, the program create a blank window...
but if I download the Linux version and run it, it work great!!??
why? \-:

[This message has been edited by NighTiger (edited 09-26-2003).]