PDA

View Full Version : GLUT errors with NVIDIA



06-29-2000, 08:04 PM
I downloaded the source rpms for X4.0, used rpm --rebuild, and upgraded my Red Hat 6.2's default X11 install. Everything works fine including Quake 3. However, when I recompile my programs, I get

GLUT: Fatal Error in graph3d: visual with necessary capabilities not found.

I then tested some of the NeHe tutorials (lessonX.c) and got the same results. The programs have been modified to use both windowing and full screen -- no go. In my XF86Config file, I have my driver specified as 'nvidia' (and not 'nv'). Using 'nv' gives a broken X11. The NVIDIA drivers (.93; also tested .92) were also rebuilt (well, the kernel driver for .93 was) using rpm --rebuild.

As for gcc options, I used:

-lX11 -lXi -lXmu -lglut -lGL -lGLU -lm

The glut libraries, along with the headers for glut, GLU, and GL were from the X4.0 distribution.

Any clues as to what I've done wrong? I can also put up links to my source if need be.

06-30-2000, 05:58 AM
Hm.. figured it out. Using GLUT_ALPHA in the window initilization causes this problem. Fixed when

glutInitDisplayMode(GLUT_RGBA | GLUT_DOUBLE | GLUT_ALPHA | GLUT_DEPTH);

was changed to

glutInitDisplayMode(GLUT_RGBA | GLUT_DOUBLE | GLUT_DEPTH);