PDA

View Full Version : Disabling VSynch / RedHat 9.0 / NVidia



pleopard
07-04-2003, 12:50 PM
I just switched to RH9 (Shrike) and It seems that my display has vertical synch locked in and I can't get more than 60 FPS on any OpenGL based app. Is there a way to disable VSync for OpenGL as there is on Windows/nVidia drivers?

shinpaughp
07-04-2003, 02:29 PM
Seems as though the vsyinc is off by default on my Redhat 9 system. Try running glxgears from the command line. Let it run for a little while and it will print out your framerate in the console/terminal window. Not sure why but it does occasionally kill the KWin process which means you'll have to log out and log back in.

richardve
07-04-2003, 04:15 PM
He doesn't mention if he's using GNOME or KDE, but as it's RH, I'd assume GNOME, which uses Metacity instead of KWin..

Anyway, as mentioned in the README (ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4363/README.txt) you should be able to disable it by setting the __GL_SYNC_TO_VBLANK env var to zero.

pleopard
07-05-2003, 08:00 AM
I'm using KDE. I'll try the glxgears thing monday when I go back to work. Any other ideas anyone?

richardve
07-05-2003, 08:47 AM
Does that env var actually work or not? ??

btw. There's also a nice tool for handling those options using Qt: http://yanc.sourceforge.net

btw2. My previous comment was stupid, please ignore..
(some times I can't read http://www.opengl.org/discussion_boards/ubb/wink.gif)

pleopard
07-05-2003, 06:02 PM
Originally posted by richardve:
Does that env var actually work or not? ??
Not for me it doesn't.

pleopard
07-05-2003, 06:03 PM
Oh Man, that Yanc looks like it might be just what I need ... Thx for the tip ...

pleopard
07-07-2003, 05:17 AM
BINGO!

yanc => r0x0rz!

Thanks!

richardve
07-07-2003, 06:16 AM
yw http://www.opengl.org/discussion_boards/ubb/smile.gif