PDA

View Full Version : extension "XFree86-DRI" missing on display ":0.0"



01-08-2004, 12:18 AM
I saw this topic recently. Actually I get the same message on my laptop compaq nx9010 with ATI Radeon IGP 340M (mandrake 9.2). What is DRI ? How can I configure it ?

dorbie
01-22-2004, 02:17 PM
DRI is the direct rendering infrastructure used for hardware accelerated OpenGL on Linux (for most cards except NVIDIA's if you use their drivers). It's a framework for direct hardware rendering and driver support for 3D graphics cards. I think if you use XFree86 version 4 it's an integral part of that system so make sure that's the xserver you're running and it should work. You may need to load it in the config file too, located in /etc/X11/XF86Config-4

In the section:

Section "Module"

add the following:

Load "dri"

You may need to add a few other things like glx, really depends what's there already.


[This message has been edited by dorbie (edited 01-22-2004).]

mjs1
01-24-2004, 11:31 AM
Yeah, I'm getting this too. I believe I'm using XFree86 4.0 (I installed Red Hat 9.0). The /etc/X11/XF86 Config file has commented at the top that it is XFree86 4.


I'm running a Diamond Viper 770 card. The Config file was automatically generated on installation of the OS. I haven't altered it yet.

Here are some excerpts from my config file:

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "Diamond Viper 770"
VideoRam 32768
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

01-30-2004, 04:34 PM
Thanks for the info. It was really helpful.

John Brinnand

dorbie
01-30-2004, 07:24 PM
sandrik, you have an NVIDIA card. You may be better off installing NVIDIA drivers from their site, they don't use the DRI, but the ABI is identical and should work with all the OpenGL software.

Get the driver here:
http://www.nvidia.com/object/linux.html

The NVIDIA instructions will tell you how to edit out the DRI load from the config file and load the NVIDIA modules. Here is a quote from their README:




If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"



This is AFTER you install their drivers, but it's pretty much all you need to know to get the job done. As you can see you replace the DRI stuff with the nvidia driver framework and it'll all just work. In my experience this gives you hardware acceleration for all 3D stuff than is normally not there before the switch.

02-15-2004, 02:18 PM
I am new to Linux so my advice may seem silly to some of you... Anyway here is what I can say:
I also had problems with DRI and I found that changing the default color depth to something lower than 24 (in my case it was 16) solved it.

Cheers ;-)