PDA

View Full Version : Unix, but not Linux problem...



mantww
01-27-2004, 10:38 AM
First off, this is first post.

Second, I'm not a s/w guy (systems "keyboard monkey"). So please forgive my ignorance on a lot of things.

At any rate, my problem is this:

I'm accessing some software that resides on a v1280 using a PC (WinXP) and Hummingbird Exceed. I keep getting this error; "Xlib: extension "GLX" missing on disply "<client name>:0.0". "

I'm running Solaris 9 on the server (v1280) with the standard factory loaded OS. I've tried researching a possible patch, but to no avail. If I understand this correctly (and please correct me if I'm wrong!) there is a problem with the X11 server and it's ability to access certain OpenGL libraries(?). Does anyone know of this or similar problems and what possible (if any) resolution they found?

Thanks again for any help... http://www.opengl.org/discussion_boards/ubb/confused.gif

roffe
01-27-2004, 11:49 AM
If I understand this correctly,
you are running an X-server app on your WinXP box to connect to the Solaris machine.

I would suggest checking any docs that the vendor of this app has for GLX support on the X server. Your X server app probably has some "configuration" setting for the X server. Start there.

/Mathias

blip
01-27-2004, 12:02 PM
do some searches on hummingbird's mailing lists for glx. From a quick glance it looks like if you want OpenGL support for Exceed it is an extra module you must purchase. This was from an older post but may still be valid. If you already have that module then it's probably a configuration error and you might try sending a message to their mailing list.

in fact from their product page

Exceed 3Dô 9.0 - An add-on product to Exceed and Exceed PowerSuite that enables high-end engineering and finite analysis OpenGL-based applications to be distributed to or developed on lower cost desktops.
http://www.hummingbird.com/products/nc/exceed/index.html

http://www.hummingbird.com/exceedusers/


[This message has been edited by blip (edited 01-27-2004).]

[This message has been edited by blip (edited 01-27-2004).]

mantww
01-27-2004, 12:08 PM
Hey Guys,

Thanks for the help! I'll do some checking...

http://www.opengl.org/discussion_boards/ubb/cool.gif

dorbie
02-04-2004, 08:48 AM
For an X server to support 3D using OpenGL is must support GLX extensions.

It seems like your installation of Hummingbird is not set up for 3D support. I have no idea why that would be, I am not familiar enough with the products although I know Hummingbird have a product that supports 3D (called Exceed 3D last time I looked).

When you say <clientname>:0.0 that clientname is the X *server*, X reverses the client server model, the server is the thing you sit in front of and look at and it *serves* display resources to remote clients, (the client being your application). If you refer to it as <displayname>:0.0 or something similar when dealing with X it'll help people who understand X be clearer on what you're discussing.

The problem here is probably not the application, it's your Hummingbird product or configuration.

As things stand Hummingbird on your system should work fine for 2D stuff, only applications that try to create an OpenGL context will have problems displaying. You probably need an upgrade to Hummingbird Exceed 3D or get your configuration fixed.

<snip>

P.P.S. oops sorry I should have read the whole thread, someone already answered the exceed3D bit.

[This message has been edited by dorbie (edited 02-04-2004).]