PDA

View Full Version : Lying about GLX extensions



hublan
07-11-2000, 05:57 PM
Right-o...

I got XFree86 4.0.1 installed from the tar bins. With it is included a Matrox G400 driver (mga), a glx extension and a brand new OpenGL library.

Now the glx driver tells me that the extension 'GLX_SGI_video_sync' is supported. But there is no evidence of the SGI_video_sync extension functions as I understand them from the SGI man pages.

If I give a declaration of one of the SGI_video_sync functions it complains with undefined ref at link time.

Is this a dead end, the assumption being that the driver is lying?

Any other way you can think of to get vertical sync?

I think it's probably one of the *biggest* oversights in the GLX standard.