PDA

View Full Version : Multitexture problems??



dabeav
05-24-2002, 10:09 AM
Here is my code, (you can ignore the IL calls, I am using OpenIL to load my images).
Else where in the code I check for the use availability of the Multitexture, and CVA extensions. Then I set the flags, to true if its supported.

if(MultiTextureSupport == true && CompiledVertexArraySupport == true)
{
ilGenImages(1, &MapImage);
ilBindImage(MapImage);
ilLoadImage(MapTextureName);
glActiveTextureARB(GL_TEXTURE0_ARB);
glEnableClientState(GL_TEXTURE_COORD_ARRAY);
glTexCoordPointer(3, GL_FLOAT, 0,&Map.Texture1PT);
ilutGLBindMipmaps();
glEnable(GL_TEXTURE_2D);
glTexEnvi(GL_TEXTURE_ENV, GL_TEXTURE_ENV_MODE, GL_MODULATE);
glColor4f(1,1,1,1);
ilDeleteImages(1, &MapImage);

ilGenImages(1, &MapLightImage);
ilBindImage(MapLightImage);
ilLoadImage(MapLightTextureName);
glActiveTextureARB(GL_TEXTURE1_ARB);
glEnableClientState(GL_TEXTURE_COORD_ARRAY);
glTexCoordPointer(3, GL_FLOAT, 0, &Map.Texture2PT);
ilutGLBindMipmaps();
glEnable(GL_TEXTURE_2D);
glTexEnvi(GL_TEXTURE_ENV, GL_TEXTURE_ENV_MODE, GL_MODULATE);
glColor4f(1,1,1,1);
ilDeleteImages(1, &MapLightImage);

glEnableClientState(GL_VERTEX_ARRAY);
glEnableClientState(GL_NORMAL_ARRAY);
glVertexPointer(3, GL_FLOAT, 0, &Map.VertPT);
glNormalPointer(GL_FLOAT, 0, &Map.NormalPT);

glLockArraysEXT(0, Map.NumInterleavedVerts);
glDrawElements(GL_TRIANGLES, 0, GL_UNSIGNED_INT, &Map.VertIndexPT);
glUnlockArraysEXT();
}

Why do I get these errors when I compile??

'int (__stdcall *)(void)' : too many actual parameters

I get this error 3 times, once for the lines containing my first glActiveTextureARB, my second glActiveTextureARB, and my glLockArraysEXT. Any ideas why this is happening? I have tried everything to get it to work, and still nothing.??.. Please help..

Humus
05-24-2002, 11:01 AM
Make sure your definition of the glActiveTexture function is correct. Judging the error it seams you have defined without parameters.