PDA

View Full Version : Pixels Buffer (WGL stuff) performance with Geforce 4



Prophet
02-22-2003, 05:01 AM
I have a question about PBuffers with OpenGl and a Geforce4 Ti (detonators 41.09)

I have inplemented a PBuffer system and a way to simulate it with hardware that don't support it. So i explicitely tested it to seen how it will perform on such old hardare :

Why do i have better performance with dynamic cube map if i render them directly on the main back buffer and so transfer it to the texture (simulation) than render them on a Cube Map Pixel Buffer (hardware support)?

In both case i use SGIS_Generate_MipMaps (MipMaps are automaticaly done when specifying the level 0), anisotropic filtering and a texture size of 128x128.
With PBuffers i have 160 FPS
With passing by the back buffer i have 280 FPS

With 1024x1024 bump map i don't see noticable performance difference :
30 FPS with back buffer
31 FPS with pixels buffers.


Both use 32 bit per pixels and a 24 bit z buffer.
On each face, i first clear the color and z buffer and then i draw a textured quad that consume exactly 1/9 of the texture surface.

If performance are not better with Pixels Buffers, why simply not use them when not required? (Or also why are they have been inplemented : The only improvement is the buffer property being different form the main buffer : bigger size ...?).

Asgard
02-22-2003, 06:58 AM
Read this thread: http://www.opengl.org/discussion_boards/ubb/Forum3/HTML/008470.html
It should answer most of your questions and also discusses other uses of pbuffers and why they are useful.

Prophet
02-22-2003, 07:31 AM
Originally posted by Asgard:
Read this thread: http://www.opengl.org/discussion_boards/ubb/Forum3/HTML/008470.html
It should answer most of your questions and also discusses other uses of pbuffers and why they are useful.

Thanks a lot! Does anybody know if i can simply always simulate Pbuffers or the performance increase a lot with ATI card or 2D textures ?