PDA

View Full Version : Dawn demo for ATI Radeons



GT5
01-23-2004, 11:50 PM
hi all,

I remember a while back someone made a version of nVidia's Dawn demo for the ATI Radeon 9500+. Some wrapper i think.

I did a search on this forum, came up with 10 topics but i cant find the link http://www.opengl.org/discussion_boards/ubb/frown.gif

Does anyone remember the link? Humus? Nutty? Dorbie? Anyone???

P.S: The reason why i am asking now is becoz i just upgraded my Geforce2Ti to a RadeonPro http://www.opengl.org/discussion_boards/ubb/smile.gif

dorbie
01-24-2004, 03:32 AM
Yea it was just an OpenGL32.dll file that you throw in the Dawn demo dir, I have this but I just tried it and it has rotted. It doesn't work because it can't find the NV_point_sprite extension and it didn't come with source.

Strange because Delphi3D's glinfo2 lists it for my card. Something strange is going on, the getProcAddress may be failing for the function name although the extension is listed. This is highly possible since we have the newer ARB point sprite. ATI may have introduced a bug here by not exposing te old entry point.

P.S. this makes no sense, there's no new entry points with this extension. Maybe the wrapper is somehow breaking this or the hardware context pixel format support changed somehow and therefore isn't reporting point sprites that it used to in this demo.

Strange, but still broken despite driver support for NV_point_sprite.

[This message has been edited by dorbie (edited 01-24-2004).]

GT5
01-24-2004, 05:22 AM
so in other words your telling me its useless because the wrapper does not work anymore? Damn!! And i was going to see how fancy this dawn demo was. Not anymore ;(

Ketzal
01-24-2004, 05:36 AM
Here:
http://www.rage3d.com/content/articles/atidawning/

dorbie
01-24-2004, 08:59 AM
It might work, probably depends on your driver version.

V-man
01-24-2004, 06:54 PM
It only works with Cat 3.4 otherwise it says it can't find NV_point_sprite
I will upgrade to 4.1 tomorrow but I'm sure it'll give the same message.

That DLL is specific to Dawn.
I tested it with my own stuff and it screws up.

I'm not even sure why it wants NV_point_sprite.
I think 3.4 didn't have it even.

tEd
01-24-2004, 08:08 PM
cat 4.1 support nv_point_sprite , it should work with those. If it doesn't just use the opengl driver from cat 3.7 you don't have to actually install them just extract the atioglxx.dll and put it into dawns install directory.

GT5
01-25-2004, 02:47 AM
thanks for that. Much appreciate it. I've got Cat 4.1 installed but I didnt know that dawn demo was 79MB in size! Looks like im going to have a hard time trying to download the thing.

dorbie
01-25-2004, 11:27 AM
I have the cat 4.1 driver. Yes it supports NV_point_sprite (it's there in the strings list detected by my own software and Tom Nuydens' glinfo2 also reports it), NO the Dawn demo does not run on it even with the wrapper. There must be something about the way it detects that particular extension at runtime that it isn't happy about, IMHO it's a bug in Dawn (fairy.exe) but it's difficult to say, maybe it makes assumptions about the order of the strings. The wrapper fixes all the other extension issues but NV_point_sprite is listed as unsupported with or without the wrapper.

It's been a while since I ran this with the wrapper so I dunno when it stopped working, I went from 9700 Pro to 9800 Pro in the interval, but it shouldn't have made a difference.

[This message has been edited by dorbie (edited 01-25-2004).]

Thorn2004
02-14-2004, 04:57 AM
I just bought a ATI 9800 XT and heard about the dawn demo being patched for ATI products, well I tried everything and I get the same error everyone else seems to be getting, is there ANY way of fixing it? I don't want to download a 70 meg demo only to find it won't work http://www.opengl.org/discussion_boards/ubb/frown.gif

dorbie
02-14-2004, 10:55 AM
You could write your own wrapper around the demo wrapper (I think that would work) or disassemble the NVIDIA demo and figure out why it's branching to a failure mode. It may be testing the wrong string at runtime for example, or the error it's reporting may be unrelated to the real reason it's failing.

It's a shame the wrapper didn't come with source code.

It may be a bug for example where the demo is doing a wglgetprocaddress on a bogus function it shouldn't be using or doesn't call (perhaps a cut 'n paste edit error because this extension exposes no new functions), OTOH it may be some change in the extension string that is causing this, the wrapper may have tweaked this and when the drivers corrected it it broke the wrapper (?).

V-man
02-14-2004, 06:46 PM
Whatever the reason is, you can always get yourself Cat 3.4 (I tested with 3.5 and it works) and just have a look for a few minutes.

Make a backup of the atiogl dll somewhere before you go back to 4.x as suggested