PDA

View Full Version : Old extensions in Longs Peak?



PaladinOfKaos
03-07-2007, 04:54 PM
My program is currently using Geometry shaders, and other SM4.0 stuff. I'm really looking forward to many of the LP features, but I don't want to deal with a second rendering context just because the SM4.0 extensions are written against OGL 2.0. I expect SM4.0 will be in Mt. Evans, but I'd like to be able to start porting to the new object system ASAP, rather than waiting those few extra months.

So, are there any plans to re-write extensions that aren't core in LP so that they work with the LP object model? Or will I just have to wait until Mt. Evans to avoid that second context?

Korval
03-07-2007, 05:31 PM
So, are there any plans to re-write extensions that aren't core in LP so that they work with the LP object model?That is as good a definition as any of what Mt. Evans is. So, no, it won't be in Longs Peak.

Overmind
03-08-2007, 02:02 AM
Hehe... Long Peaks is not even out yet, and people are already getting impatient for Mt. Evans ;)

You have to wait for the drivers supporting both versions anyway :p