PDA

View Full Version : sudden ~5 fold slow down after reinstalling os and compiler | win2000 msvc



opengl_enquirer
09-29-2003, 10:26 AM
salutations everyone,

it is my hope that i might find support amongst your ranks so that i may alleviate a sudden and dibilitating circumstance.

a few days ago i was forced to reinstall the operating system and compiler/browser. this began as so many ms bugs had accumulated i thought it might be time to reset everything. unfortunately in this process an ms bug aparently formatted the second partition on my harddrive where most of my crucial files were that aren't backed up. so now i'm left only with my most important regularly backed up files, but lost a lot of the libraries and what not i had collected which i did not personally develope. and on top of all of this all of the bugs were back withing a day or less, the worst of which the inability to use precompiled headers in compilation and crazy copy/paste bugs that occur after using ms explorer for a few minutes. not to mention i lost most of my hardware drivers which i can't find a means to replace leaving the system quite impotent.

anyhow i thought that i had replaced everything and all seemed to be in order until today i realized that my project of more than half a years development day in and out now is actually running at aproximately 1/5th more or less as i guess of what it would do just a week ago before the system was "reset". i didn't realize this because i had not brought enough of the system online to fall below 60 fps which is the celing.

i had been working with graphics hardware in preparation for a new quadro fx card i am expecting any day now. i thought the extreme slowdown was merely because the card i've been using 'geforce3' didn't feel the performance bill so to speak, hardware shadow /*mapping*/ (edit: meant 'shadow volumes") and bump mapping i was implimenting for that superficial flair that draws the untrained eye. any how now i realize that was less the case then it seems, the resulting performance hit that is.

anyhow so far i've tried replacing the opengl libraries with the newest i can find, installing the best detonator drivers i could find. that is all i can think off. there is only one other thing, i am using a student evaluation verson of msvc, but before i began working with this project back in january or febuary someone had suggested a trick to install the newer msvc service packs so i could get simd support, which caused a lot of bugs but did allow for limited simd support. could this make a difference. incidently the evaluation version has a lot of restrictions including no upgrade to sp4+ and the abscence of many features. i can't afford a liscensed version for political reasons, and can't afford to work with linux, though i would like to, because of mostly phychological reasons, and because i currently only have one computer now that about 5 of my computers died perhaps as a result of working with linux. i can talk more of my perspective on linux if anyone wishes me to. i would like to wipe my hands of ms but am not ready for a sudden pardigm shift and can't afford a gradual one with only one computer on hand. plus i'm spoiled on the browser aspect of msvc, if the is a linux analog to this i would very much like to know, but otherwise i would hve to develope my own browser if i was to transfer to linux development.


in anycase back to the point... 5 fold slow down is completely unworkable. and i'm not going to be willing to install the new graphics card before i determine the source of this problem because i would never really know if it is trully running at full performance or 1/5th.

the slow down appears to be general in nature. there is nothing in the code causing the performance hit.

i hate to think that it might be possible to somehow end up with this system configuration never to know that your graphics card is capable of so much more.

this is extremely serious, i wouldn't be surprised if the slowdown is 10 fold, in lieu of this i would greatly apreciate any input possible, as this development places a large part of my life on hold.

sincerely,

opengl_enquirer

[This message has been edited by opengl_enquirer (edited 09-29-2003).]

[This message has been edited by opengl_enquirer (edited 09-29-2003).]

jra101
09-29-2003, 10:54 AM
Did you disable vsync?

opengl_enquirer
09-29-2003, 11:06 AM
i'm not familiar with that feature, i will see what i can find... i'm willing to try anything at this point. after reevaluating the situation i think the slow down is more like 20 fold... completely unusable in other words, i'm really surprised it renders anything.

vsync you say, where would i look into that, provided i don't find it shortly after looking.

sincerely,

michael

PS: "Vertical Sync" is set to "On by default". i presume that is vsync, so the answer is no it is not disabled. thanks in any case though.

[This message has been edited by opengl_enquirer (edited 09-29-2003).]

opengl_enquirer
09-29-2003, 11:14 AM
anyone know of a diagnosis utility that tests graphics card performance compared to what it should be for a given system configuration?

opengl_enquirer
09-29-2003, 11:30 AM
you should be more explicit i think. i had presumed that you, the first repy, suggested disabling vsync would cause severe slow down. but in any case i disabled it to see if it indeed created more slow down, and it alleviated a lot of slow down. which lead me to the conclusion that your suggestion was to disable vsync. but still very much slow down still exists. i will try fiddling with some of the other options, but its worth noting that before the system reinstallation i never recall disabling vsync, which means perhaps in the past i could've got much better performance, but perhaps i did disable and do not recall. but never the less very much slow down still exists so i would apreciate any further suggestions possible.

sincerely,

michael

jra101
09-29-2003, 11:53 AM
When vsync is enabled, your redraw is synced to your monitor refresh so the maximum FPS you'll get is whatever your monitor is set too (usually 60, 75, 80, or 100). When its disabled, your app can redraw as fast as the video card can render.

opengl_enquirer
09-29-2003, 12:47 PM
thats a relief, a fortunate article reminded me of the via 4in1 drivers which include an agp driver and whatever else. anyhow that corrected the problem... the loss was about 7 or 8 fold.

questions about vsync... i had thought windows limited the framerate. an aquaintance had once told me how to turn this off. but i didn't mind because 60 is fine by me, and i thought that would alleviate unnecesarry cycles. still when the performance was well below 60 disabling vsync brought it back up to just near 60. so in the case that frames are running below 60 perhaps disabling this could be advantageous. so i guess my final question is is it possible to control vsync from teh aplication perspective turning it off and on as frame rates slip.

thanks for what its worth.

sincerely,

michael

jra101
09-29-2003, 01:03 PM
Yes, use the WGL_EXT_swap_control extension (http://oss.sgi.com/projects/ogl-sample/registry/EXT/wgl_swap_control.txt).

M/\dm/\n
09-29-2003, 08:10 PM
Make sure you arn't using windoZes drivers for your vcard etc. glGetString(GL_RENDERER);+glGetString(GL_VENDOR);+ glGetString(GL_VERSION);
Win drivers are rrrrrrrrreeeeeally crappy for everything but DX.

opengl_enquirer
09-30-2003, 09:31 AM
i use the current detonator drivers as i mentioned which are not windows drivers as far as i know but i'm interested in any alternative drivers that might milk better performance.

and thanks for the WGL_EXT_swap_control extension btw.

michael