PDA

View Full Version : GeForce2 MX Z-buffer



compactive
09-29-2000, 01:00 AM
Hi,

We bought a new Asus7100 GF2MX graphic card. We use an OpenGL-powered 3D technology and with this card, horrible Z-buffer artifacts revealed. No matter how deep we set the Z-buffer, the stuff looks like if it were 8 bits (ridiculous, eh?) Very ugly sawtooth cuts appear on the screen.

We used TNT2 and Permedia2 cards before but we have never encountered such a problem (even with the 16-bit Z-buffer on the PM2).

The programmer of the engine is not avaliable at the time but we need a solution fast. We cannot go back to TNT2, we need the speed.

What do you know about this specific card? Any experiences? Any solution?

Thx,
Compactive

Firestorm
09-29-2000, 07:11 AM
I don't own a geforce2, but i've heard that indeed zbuffer artifacts appear on the geforce2 and that it's because of the 6.18 driver, previous drivers don't seem to have the problems..
(altho i'm not sure if the geforce2 will actually work with older drivers)

DJ Tricky S
09-29-2000, 07:32 AM
Does turning off FSAA help any? There are some problems related to the depth buffer on GeForce cards when FSAA is enabled.

Bob
09-29-2000, 09:38 AM
In most cases, depthbuffer artifacts occurs becasue the user places the near clipping plane too close compared to the distance to the far plane. Becasue of the way a frustum and the floating points works, artifacts is unavoidable, you can only make them less visible. What you need to do is place the near clipping plane further away, or the far plane closer. It's the relative distance that matters. A near to far ratio of 1e3 to 1e5 is usually ok, depending on the depthbuffer precision. The ratio is the value of the far plane divided with the value of the near plane.

What I don't understand is why it look OK on other cards...

compactive
10-02-2000, 05:05 AM
Hi,

Thanks to all!

>In most cases, depthbuffer artifacts occurs becasue the user places the near clipping plane too close compared to the distance to the far plane.

Meanwhile we found the problem you describe here, thanks. And yes, it doesn't appear on the cards we used till now... Strange :eek:

Bye,
Peter