PDA

View Full Version : Random texture distortion



Csquared
08-25-2000, 09:53 AM
In creating a game for fun, I somehow caused a hideous texture error. It happened, strangely enough, just by adding the full path to bitmap names before loading them. Suddenly and arbitrarily, some of my textures would not draw, and would get distorted when they were clipped. I have a picture before this error at: http://www.frontiernet.net/~mcameron/mbc2.jpg and a picture after at: http://www.frontiernet.net/~mcameron/mbc1.jpg
What caused this and how can I get rid of it?

john
08-26-2000, 05:07 AM
this wouldn't be an ogl error; more likely some bug in your code when you use strings.

You could easily be trashing memory you shouldn't by writing a longer string (the texture with full path) to a string with insufficient space, for example) and doing something really weird with your texture ids, or something. who knows?

opengl doesn't worry about loading textures from disk, so you can IMMEDIATELY elimiate opengl as the problem. trace write your bitmap loader. use a debugger, or something

cheers,
John

Csquared
08-26-2000, 11:29 AM
I found that this problem did not appear on my brother's computer, with a Diamond Viper V330. Also, some of the distortion was removed when I upgraded drivers on my computer. I think that the problem is with my card (Voodoo3 3500). This is actually kinda similar to an old problem with Quake3. Anyhoo, thanks, just like my teeth, if i ignore it long enough and update my drivers, it'll go away.