PDA

View Full Version : Attenuation map trouble



nobodii
06-29-2002, 10:19 PM
Hi there.
Im using a 3D texture for per pixel correct attenuation. I can clearly "see" the sphere, but there also are some strange thick lines that seem to extand in the 6 directions (top bottom left ..).
I have overlooked my code but cant find out the probleme.
Im using GL_CLAMP_TO_EDGE, and im sure the texture is correct ..
Any clue out there ?

davepermen
06-30-2002, 02:52 AM
the outermost part of the cube has to be completely black, are you sure about that? it looks like the attentuationsphere touches the outsides of your textures (if it would be a solid cube, you would see some white dots in the middle of each side of the cube). this then gets expanded to infinity with gl_clamp or gl_clamp_to_edge..

Coop
06-30-2002, 06:56 AM
It's probably because of mipmapping. Make sure that there's a black border on ALL mipmap levels (so two smallest mipmaps have to be completely black actually). If you are sure that your base texture is correct, try to disable mipmapping to test if it's the case.

nobodii
06-30-2002, 07:55 AM
It really is weard, i just changed the tex size, and now it works (well, seems like, at least http://www.opengl.org/discussion_boards/ubb/smile.gif ) .. that should not happen, as im sure the math is correct ..

thanks anyway for trying to help

dorbie
06-30-2002, 10:12 AM
Changing the texture size would affect the MIP lod applied. If you reduced the size and it works then turn off MIP mapping on that texture (or load MIP levels). If you increased the size then you have a very strange problem.

You need to fix this, because changing the screen resolution or user adjustable parameters like anisotropic texture & mip map quality could mess it up again.

nobodii
06-30-2002, 01:20 PM
you're right, it _really_ is weird : i wasnt using mipmaping, and i increased the size .. anyway, it works just fine now ..
maybe a bug in nvidia's linux driver ?

nobodii
06-30-2002, 01:32 PM
Well .. dont know what to do ??.. i changed the screen res up to 1024, and i had to enlarge the texture, once again, to get rid of the problem ..

dorbie
07-01-2002, 04:21 PM
Hmm.... this has to be texture filters. Try a GL_NEAREST minification filter just for kicks.