PDA

View Full Version : PB Nvidia libGL.so



malrog98
03-13-2001, 09:26 AM
hi,


i have a linux mandrake 7.2 , with a Nvidia Gforce2.
i m install 0.96 version of drivers for this card.

the drivers install a new libGL.so

when i make a soft , it tell the glPolygonOFFsetEXt is not in the library.

when i see with 'strings libGL.so' , it is not present.

if i see in the libGL.so of MESA, it's present.

can you tell why the lib of Nvidia not implement this ??
it is normal???


thanks

Siigron
03-13-2001, 10:59 AM
it is called glPolygonOffset, and is not an extension in OpenGL 1.2. if you look for glPolygonOffset, you should find it.

malrog98
03-13-2001, 03:59 PM
Originally posted by Siigron:
it is called glPolygonOffset, and is not an extension in OpenGL 1.2. if you look for glPolygonOffset, you should find it.

In Mesa lib there are glPolygonOffset and glPolygonOffsetEXT.
glPolygonOffset , it s not a standard for OpenGL 1.2????

Serge K
03-13-2001, 06:49 PM
forget about glPolygonOffsetEXT - GL_EXT_polygon_offset is obsolet with OpenGL 1.0
You should use glPolygonOffset.

Relic
03-14-2001, 01:43 AM
>>forget about glPolygonOffsetEXT - GL_EXT_polygon_offset is obsolet with OpenGL 1.0

Actually with 1.1.

Serge K
03-14-2001, 11:39 AM
Originally posted by Relic:
Actually with 1.1.[/B]

I mean - GL_EXT_polygon_offset AND OpenGL 1.0 are both obsolet.