PDA

View Full Version : SGIX_shadow extension with clipping planes -Terribly slow!!



Marcus010101
04-12-2002, 10:56 AM
I have 10s of light sources in a scene with shadows. I am creating shadow maps using SGIX_shadow extension. When I use clipping planes to get rid of the back projection problem, it becomes really slow. How can I get rid of the back projection problem without slowing down the system?

Is this unique to GeForce4?

Cass, you have any idea?

davepermen
04-12-2002, 11:02 AM
clipplanes are in software.. bether use texture_shaders with texkill or how ever called.. four clipplanes with only one texture-stage..

harsman
04-13-2002, 02:52 AM
Like davepermen said, clip planes are done with texturing on the GeForce series. If you're using all four texunits already it might start to do clipplanes in software which will be slow. You can probably improve efficiency by using your own custom texture shaders to do clip planes.

cass
04-13-2002, 05:07 AM
Marcus,

Yes, GeForce series uses interpolant resources to perform user-clip. If you use all your texture stages, then enable clip planes, you'll run in software.

Thanks -
Cass

davepermen
04-13-2002, 05:45 AM
when will there be finally more interpolators.... not more textures, only more interpolators... (and sampling severall times from different textures more or less like the ati http://www.opengl.org/discussion_boards/ubb/wink.gif)

Marcus010101
04-13-2002, 10:36 AM
Thanks for the answers guys ...

I am using only two textures per pass in GeForce4!!! So I have two more textures to use for clip-planes or texture-culling ...

Both are slowing the system incredibly!

It should be running in software as you have said, even though I have unused textures... Is there anyway I can force it to be in hardware ? or correct the mistake the driver(? I guess) is making?

What I am doing is very simple, I do not think I am doing anything wrong...

dorbie
04-13-2002, 10:48 AM
How many glLights do you have enabled?

timfoleysama
04-13-2002, 11:08 AM
I'm not sure if this is the case (somebody from nVidia would have to confirm or deny it) but if you are currently using two texture units then adding a clip plane might have the same effect on fill-rate as adding another texture. I believe that a GF3 runs at full speed with 1 or 2 textures, and drops to half-speed with 3 or 4 textures. So some questions to ask are:

1) Is your program fill-rate limited, and if so is the slowdown consistent with halving the effective fill-rate?

2) Does adding another texture (but not neccesarily sampling it) have no effect on performance?

Anyway, it's just a possible explanation, but it certainly won't help you improve performance...

Marcus010101
04-13-2002, 11:36 AM
Originally posted by dorbie:
How many glLights do you have enabled?

I have 12 shadowmaps but only one light source...

davepermen
04-13-2002, 11:55 AM
i told you. use textureshaders. with them you can do 4 hardwareclipplanes in one of the 4 texture-units