PDA

View Full Version : Cat 3.8s fix window resize crash



CatAtWork
10-08-2003, 11:17 AM
My app which loaded thousands of display lists would crash on a window resize (inside ATi's driver.) No longer exhibits this behavior.

If you don't feel this isn't appropriate for the forum, just let me know. I find these types of threads helpful, as I often encounter annoying small bugs, but don't post them.

sqrt[-1]
10-09-2003, 02:42 PM
I have to agree, the 3.8's have fixed a lot of my bugs and performance problems. (esp. with vertex program generic attributes)

I also like the "SmartShader" effects you can apply to OpenGL apps. Go View Settings advanced->3D->Select OpenGL->Click custom->Smart shader effects.

I like "Sketch" and "classic"..

davepermen
10-09-2003, 04:28 PM
i was never able to run the hdri realtime demo in dx9 wich looks so nice, on my very own hw configuration. the mainboard is just..... no comment. i can run it everywhere else with my card, just not in my own pc.. hehe

it always crashed to freeze so it was THE test to the new savetyguard ati built around it, to prevent bluescreens in such cases. and yeah, it worked, reset to desktop, and wanted to mail the report..

then i got a blackscreen. and my pc hasn't showed up to do any task since then.. after a while i reset, and watched into outlook. there was no sent mail.. so i'm not sure now if that worked or not.

what i know is, that new savety thingy is not yet perfect.. http://www.opengl.org/discussion_boards/ubb/frown.gif

oh, but, the demo never ran that LONG without crashing the system http://www.opengl.org/discussion_boards/ubb/biggrin.gif


else, great job. you cannot blame ati for that ****ty mainboard http://www.opengl.org/discussion_boards/ubb/biggrin.gif it works in all other systems..

/me waits for his amd64

Elixer
10-09-2003, 05:09 PM
Just what mainboard do you got davepermen
?

I also wonder how they are doing the prevent the BSOD? Some kind of trap calling that catches basic errors? Or do they check each and every command before it reaches the GPU (although this would make me think it would be way too slow)

I am mainly curious as to the stability of the drivers. As I have said before, ATI + rage 128 left me with a VERY bad taste in my mouth.

Korval
10-09-2003, 08:20 PM
ATi's a long way from the Rage 128 days. You don't have to worry about whether or not your card will work. Common problems these days include the odd problem with vertex program generic attributes or the occasional game that exhibits some small visual problem.

In short, you should not feel afraid picking an ATi card on the basis of their drivers.

DopeFish
10-09-2003, 09:48 PM
I like that these drivers have glslang support exposed :P

Playing quake with the green text smartshader is trippy too... kinda hard tho

Mazy
10-09-2003, 10:30 PM
No glSlang, No version 1.4/1.5, no betatest of ARB uber_buffers ( but the ATI_uber_buffers seems to be there, but i have no constants to try it)
I havent had any real problems with sability before, and i havent tested teh generic attributes yet ( that seems like a good thing).. But why did they waste time on the shader effects, and not on making it with a higher opengl versionnumber?

They had glslang GL2 in some kind of beta version back in 3.6 drivers, remved that but didnt exposed the newer glslang ARB ( ive seen the calls in the driver, i think they just disable it for release), Giving us the oppertunity to test the API even if the extension still is very buggy should be a good thing. They done that before with VBO, and the implementations of that was pretty much fixes when the drivers that exposed the exstension came out. More of things like that.

Korval
10-09-2003, 10:31 PM
I like that these drivers have glslang support exposed

The ARB extensions for glslang? Why are we only hearing about this now? http://www.opengl.org/discussion_boards/ubb/eek.gif
I could have been playing around with its linking facility for the past 4 days.

Mazy
10-09-2003, 11:38 PM
I can find the 'glCompileShaderARB' and similar in the dll, but i cant get a pointer to them via wglGetProcAdress.. sure they are exposed ??

davepermen
10-10-2003, 03:17 AM
it's in the drivers since long, but not exposed, no..

i have some shuttlemainboard with sis864 or what ever chipset on.. one moment..

and cheap noname ddr rams, and celeron2gig.. they don't like each other, all of them.. http://www.opengl.org/discussion_boards/ubb/biggrin.gif

it was never planned to last that long actually, but i think i can life with it till christmas.. around then, i should be able to get an athlon64 with a shuttle xpc.. hehe http://www.opengl.org/discussion_boards/ubb/biggrin.gif

zeckensack
10-10-2003, 04:26 AM
In the original spirit of the thread, Cat 3.8 fixes ATI_fragment_shader and fixed function fog interaction on R300.

CatAtWork
10-10-2003, 04:48 AM
This stuff is nice to know, as the release notes only include bug-fix information for the end-user, not developers.

DopeFish
10-10-2003, 05:43 AM
Hmm not working via wglGetProcAddress?

The extension string is displayed here, and the glslang samples Ive got run... and Im using Cat3.8

zeckensack
10-10-2003, 07:42 AM
Originally posted by DopeFish:
Hmm not working via wglGetProcAddress?

The extension string is displayed here, and the glslang samples Ive got run... and Im using Cat3.8Me too, and I don't have any new exposed extensions. Maybe it's because I'm on R300 (9500Pro), and you are on R350 (9800)?

Just to get this on the record, my GL version is 1.3.3966. The reports should start showing up on Delphi3D any day now.

Korval
10-10-2003, 12:48 PM
I'm using an 9500Pro too, and I'm not getting the extension string or the function pointers.

Korval
10-10-2003, 06:24 PM
As an addendum, my driver version says that it is 6.14.10.6387. According to Delphi3d, the 6.14.10.4008 drivers expose the extensions for glslang.

Anyone got any ideas how to get this revision of the drivers?

[edit]
According to GLInfo, my drivers are the 6.14.10.3966 version. So the 4008's are more recent. Hopefully, 3.9 will have glslang support.

[This message has been edited by Korval (edited 10-10-2003).]

davepermen
10-11-2003, 01:03 AM
i have 6.14.10.3966 and no glslang eighter..

gator
10-11-2003, 03:23 PM
Whoa, 25MB to download the Cataylst 3.8 drivers. Not exactly dialup friendly.
I think I'll pass this time.

KRONOS
10-11-2003, 04:32 PM
By the way, in the det 52.14, ARB_occlusion_query and ARB_point_sprite are in the extension string, and the version is 1.4.1. And they are working very well...

I have a GF3 so I don't know if the shader objects are available.

kansler
10-12-2003, 02:10 AM
Originally posted by gator:
Whoa, 25MB to download the Cataylst 3.8 drivers. Not exactly dialup friendly.
I think I'll pass this time.

If you took the time to scroll down you would have seen versions for low speed connections. The display driver is 'only' 7.8 MB.