PDA

View Full Version : 1.2 or 1.3 gl.h



azcoder
03-01-2003, 06:02 AM
Why is it so difficult to find the 1.2 or 1.3 gl.h file? Why not post a link on the main opengl.org site just for this header file. I've got the latest drivers that support 1.3 on both nvidia and ati machines. But neither vendor updats the gl.h. What is the deal? gl.h is the same for all cards isn't it? Only the .lib and .dll vary by card?

Thanks for any help

Asgard
03-01-2003, 06:52 AM
On Windows, the problem is that you have to use wglGetProcAddress to get OpenGL functionality newer than 1.1, since the software renderer in opengl32.dll only offers support for version 1.1, and the ICD mechanism works in such a way that you should not directly link against the OpenGL driver provided by the hardware-vendor (which will have a different name for each vendor anyway).

I suggest you use one of the freely available OpenGL extension libraries, such as this one http://glew.sourceforge.net/ to use all the OpenGL features of your graphics card.

rgpc
03-01-2003, 04:22 PM
It's not difficult to get the latest gl.h at all. They are included in the SDK's provided by the Vendor that developed your card. Of course it's not just gl.h that is required. You also need glext.h and wglext.h and ...