PDA

View Full Version : clip planes & NVIDIA detonator XP driver problems



heeb
04-20-2002, 10:16 AM
Just downloaded the latest nvidia detonator XP drivers (28.32) for Win98 and my current project now runs at < 1 fps (probably now in s/w mode cos with old driver was > 40fps).

The problem seems to be due to using glClipPlane and VAR/Fence at the same time, since if I comment out
glEnable(GL_CLIP_PLANE0);
glClipPlane(GL_CLIP_PLANE0, clipPlane);

it runs at full speed, or if I leave the above in and disable VAR/Fence it runs at full non-VAR/Fence speed.

H/w is geforce3 Ti200. I only use TMU 0 & 1.

Anyone have any ideas why?

heeb
04-20-2002, 11:10 AM
ok, must be driver bug. Went back to 23.12 driver and problem goes away.

It seems fairly easy to reproduce with the nvidia sdk:

Install 28.32 driver
In the learning_VAR demo add the following after object.apply_transform();

double clipPlane[] = { 1, 0, 0, 0 };
glEnable(GL_CLIP_PLANE0);
glClipPlane(GL_CLIP_PLANE0, clipPlane);

and

glDisable(GL_CLIP_PLANE0);

before swapping buffers.
Demo now runs at about 1 fps.
Re-install 23.12 drivers - demo runs normally.

Can someone from NVIDIA confirm if its a bug or if I'm doing something stupid?

Thanks In Advance


[This message has been edited by heeb (edited 04-20-2002).]

heeb
04-20-2002, 12:48 PM
Anyone know how to report possible driver problems direct to nvidia? I looked on their site but it only seems possible if you're a registered developer.

heeb
04-22-2002, 08:23 AM
I guess from the stony silence that this was a stupid post but can someone please take a moment to explain why it was stupid.

Thanks In Advance.

PS. I did do a site search to check that no-one had reported similar problems and I did check the nvidia docs for restrictions on using clip planes with VAR/Fence.

Zeno
04-22-2002, 08:28 AM
Your post isn't stupid. Unfortunately, I think that the best way to report nvidia driver bugs is right here on this board.

You'll have to wait for Matt or Cass to respond, but what they'll ask for is a small demo application that shows the bug.

-- Zeno

cass
04-22-2002, 10:39 AM
Yes, if you think you have a bug, please send a small example (both source and exe), and we'll check it out.

Thanks -
Cass

heeb
04-22-2002, 01:15 PM
Well the learning_VAR demo is right off the nvidia web site, you only have to add four lines in the places I've indicated. But I'll try and put together something smaller and email it.