PDA

View Full Version : texture problems



lucidmm
05-03-2002, 07:04 AM
This computer has a Geforce 2 and it's running Windows 2000.

I wrote a simple program using Glut. I tried to map a texture onto two triangles that form a square. Unfortunately, the texture is cracked along the diagonal of the square where the two triangles meet. Furthermore, the program runs incredibly slowly.

However, the same program written without using glut runs fine with no texture problems. Anyone know what the problem is?

maymonni
05-03-2002, 07:52 AM
verify that your drivers are from nvidia (drivers "detonator") and are not generic drivers by microsoft !!!

lucidmm
05-03-2002, 09:15 AM
The drivers are from Nvidia.

Zeno
05-03-2002, 10:43 AM
How are you initializing GLUT? Maybe you are asking for some sort of buffer that isn't supported in hardware?

-- Zeno

V-man
05-03-2002, 03:05 PM
You're looking at the square straight on or from an angle? Because it could be a perspective correct texture coordinate issue.

Make your glut window like this on all systems:

glutInitDisplayMode(GLUT_RGBA | GLUT_DEPTH |GLUT_DOUBLE);

and plug in whatever else you need. GLUT_RGBA is for 32 bpp and set your desktop to 32 bpp as well.

V-man

lucidmm
05-06-2002, 04:13 AM
I'm looking at all the square right on. I am using your glutInitDisplayMode(GLUT_RGBA |GLUT_DEPTH |GLUT_DOUBLE);

The program runs perfectly at home on my Radeon 8500, but here it runs very slowly on the GeForce2, and there are a lot of texture problems.