PDA

View Full Version : Mulittexturing



wow
01-09-2004, 05:32 PM
Hi, I would like to ask which version of OpenGL support mutlitexturing? As I dont know what version of OpenGL I am sure but I just know that my OpenGL version does not support multitexturing.. And how can I change the version so that I can use mutlitexturing'? Thx a lot
It is of urgent matter...

JanHH
01-09-2004, 06:35 PM
you rather have to find out if your graphics card supports multitexturing, rather than if OpenGL. Multitexturing is an extension, so you first have to initialize the functions (guess you are using windows) that are used, and need appropriate headers.

Multitexturing is quite old, I think the arb extension exists since 1.2 (quake 2).

And now please don't ask how to use extensions, there is SO much about that everywhere http://www.opengl.org/discussion_boards/ubb/wink.gif.

Jan

Ostsol
01-09-2004, 06:40 PM
Multitexturing has been part of the core functionality since OpenGL 1.2.1. However, the gl.h file for Visual Studio is stuck at version 1.1. This does not mean that you can only use OpenGL 1.1 functionality, though. The version that you can use is determined by your video card drivers. All such functionality is accessed via extensions.