PDA

View Full Version : How do I disable ALT + TAB in Win32?



Hull
04-20-2001, 09:16 AM
I know the issue has been battered before, but no real solution was found.

With win2000 and the latest drivers from Nvidia for my Riva TNT2 card, the program reacts in the following way on ALT + TAB:


Computer reboots immideately. http://www.opengl.org/discussion_boards/ubb/eek.gif


This happens with other major games aswell (Tribes2), but not Quake3, because Mr Carmack disabled the ALT + TAB feature under fullscreen.

Now I need that feature aswell...

Any clues?

lpVoid
04-20-2001, 10:19 AM
http://support.microsoft.com/support/kb/articles/Q226/3/59.ASP

WhatEver
04-20-2001, 12:03 PM
Ya hooooo!!! I disabled the screensaver with that function http://www.opengl.org/discussion_boards/ubb/biggrin.gif. Thanks for unintentionally helping me lpVoid http://www.opengl.org/discussion_boards/ubb/biggrin.gif.

zed
04-20-2001, 02:07 PM
i believe its your drivers sometimes the most recent ones aint the most stable. personally ive found 10.80 to be more stable than 11.x also 6.34 is far more stable than 6.50

lpVoid
04-20-2001, 03:36 PM
my sarcasm filter isn't loaded at the moment, so either....

glad I could help

-or-

sorry

Dave

WhatEver
04-20-2001, 06:15 PM
No sarchasm here! I have been meaning to ask how to disable screensavers! I guess if you wait long enough though someone will ask the question for you http://www.opengl.org/discussion_boards/ubb/smile.gif.

Hull
04-20-2001, 08:10 PM
10X (XX,Thanks) for the link 'local void pointer',
I have now implemented the Hooks and it works as assumed.

I don't know if this makes it a window NT and windows2000 only application or if it can be run under win95/win98 aswell without recompiled binaries.

I threw in the win95/win98 version of block aswell to be sure.

Im atleast glad that I could help WhatEver aswell http://www.opengl.org/discussion_boards/ubb/wink.gif , although somewhat indirect.