PDA

View Full Version : Help! Opengl programs no longer executing.



indigo0086
06-13-2007, 02:51 PM
There's not much else to say about it, everytime I try to run an opengl program the application crashes. If I'm compiling it myself it ususally crashes before it executes the first instruction in main. When I try to debug I get a segmentation fault error. Oh man I really need to fisx this problem, can anyone help. I really have no Idea why it's doing this so it's hard for me to narrow down the possibilities. I have the latest graphics card drivers and just don't know where to look.

Darren Taylor
06-13-2007, 03:41 PM
It may just be your libraries are screwed or something.

I would download some other OpenGL programs off the net first to make sure they work - otherwise you'll never know what the root of the problem is.

Start at:

http://nehe.gamedev.net/lesson.asp?index=01

If these work, you know it's your own project setup that's going wrong and you can narrow it down from there.

Paste your own code over one of the examples and save it as a new project. This has gotten me out of similar predicaments before. ;)


Daz

indigo0086
06-13-2007, 04:01 PM
I've used other opengl programs with the same problem. They start up then I get a windows error message and I end the program now.

Darren Taylor
06-15-2007, 04:17 AM
So it must be your dll's or the drivers for your graphics card that aren't working properly.

Can you get any video games or other applications that use opengl to run on your machine?


Daz

dorbie
06-26-2007, 12:54 AM
Update your graphics drivers.

Download glinfo2 from here and run it for additional information on what is happening:

http://www.delphi3d.net/hardware/index.php

Microsoft intentionally made this difficult, but you'll be OK if you update.