PDA

View Full Version : problems linking nvparse



xboct
01-15-2004, 02:56 AM
Hi people,
if i'm trying to link Nvidia's nvparse library to my Visual C++ 6.0 project by including "nvparse.h" file and "nvparse.lib" library, my compiler/linker outputs the foloowing error code:
Compiling...
ogl_texture.cpp
Linking...
LINK : warning LNK4098: defaultlib "LIBC" conflicts with use of other libs; use /NODEFAULTLIB:library
nvparse.lib(ps1.0_program.obj) : error LNK2001: unresolved external symbol _glCombinerStageParameterfvNV
nvparse.lib(rc1.0_general.obj) : error LNK2001: unresolved external symbol _glCombinerStageParameterfvNV
nvparse.lib(vp1.0_impl.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(vsp1.0_impl.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(vcp1.0_impl.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(ps1.0_program.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(vs1.0_inst_list.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(ts1.0_inst_list.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(rc1.0_combiners.obj) : error LNK2001: unresolved external symbol _glh_init_extensions
nvparse.lib(vs1.0_inst_list.obj) : error LNK2001: unresolved external symbol _glLoadProgramNV
nvparse.lib(vp1.0_impl.obj) : error LNK2001: unresolved external symbol _glLoadProgramNV
nvparse.lib(vsp1.0_impl.obj) : error LNK2001: unresolved external symbol _glLoadProgramNV
nvparse.lib(vcp1.0_impl.obj) : error LNK2001: unresolved external symbol _glProgramParameter4fvNV
nvparse.lib(vcp1.0_impl.obj) : error LNK2001: unresolved external symbol _glTrackMatrixNV
Debug/ogl_texture.exe : fatal error LNK1120: 5 unresolved externals
Error executing link.exe.

ogl_texture.exe - 15 error(s), 1 warning(s)
Any ideas, what i'm doing wrong?

Thanks a lot.

dorbie
01-15-2004, 04:01 AM
nvparse appears to have dependencies on other libraries that you aren't linking to or at least your versions of those libs are missing some functions.

Do you have the full NVIDIA SDK installed?

xboct
01-15-2004, 04:06 AM
Thanks for the quick answer!
I don't have the SDK installed on my PC.
What is this, why does i need it and where can I get it? http://www.opengl.org/discussion_boards/ubb/smile.gif
Thanks.

dorbie
01-15-2004, 08:21 AM
http://developer.nvidia.com/page/home
http://developer.nvidia.com/page/nvsdk.html

I think there's a big installable you can just download but it's been a while since I did that and I don't see it. I still have the effects browser installed etc there but I'm not sure if there still is a monolithic download you can grab. Rummage around and see if you can find it.

I also like to use the standard OpenGL extension headers from opengl.org and I don't think the vendor specific XDKs headers play nice with each others tokens (at least they haven't always in the past) so it's always good to grab the headers from here and make sure these are the ones you include reguardless of vendor:
http://oss.sgi.com/projects/ogl-sample/sdk.html