PDA

View Full Version : I need the following file 'glut.h'



12-24-2002, 03:15 PM
I don't have it for some reason. I got all the other ones in the standart directory but not that one. (#include <gl\glut.h> )

can someone post the code to the file here so I can create a new header file and save it where the other ones are. Better yet point me to a download since I couldn't find it on the main page.


thank you very much.

psybases
12-24-2002, 03:33 PM
Are u on Unix or on Windows?

Deiussum
12-24-2002, 04:08 PM
You'll need more than just the header. You'll also need the library file. And what version of the library file is going to be specific to the compiler you use.

nexusone
12-24-2002, 05:26 PM
Best to keep .h files in the correct directory, so when someone is helping you, you don't have some wierd setup then the one everyone else uses.

\...\include\GL\glut.h
\...\include\GL\glu.h
\...\include\GL\gl.h

In order for you to get the correct version of glut, we need to know the OS that you are using and the compiler.


Originally posted by n00bster:
I don't have it for some reason. I got all the other ones in the standart directory but not that one. (#include <gl\glut.h> )

can someone post the code to the file here so I can create a new header file and save it where the other ones are. Better yet point me to a download since I couldn't find it on the main page.


thank you very much.

jmg
12-24-2002, 07:34 PM
noob, what OS/distro are you using?

I had this problem with Mandrake 8.2. Ended up downloading the proper version of the mesa-demos file just to get the header.

12-24-2002, 10:19 PM
Thank you for the replies, went searching some more and found what I was looking for at www.pscode.com (http://www.pscode.com) under the C++ section doing a search for "openGL", was like page 3 of the 5 pages returned (can't remember). It was called 'OpenGL libraries and headers' (I think, can't remember).

I am currently using WinXP but I am using openGL for my game to be compatible on my Mandrake 8.1 system. OpenGL is so much nicer then DX (I've used em since 5 to 8.1). Fully portable and I don't need to rewrite my engine everytime a new version comes out.

Thank you for the replies, seeing as this forum is active I'll show up in the future with some more questions.


Thank you again