PDA

View Full Version : VC++ 6.0 again...



03-09-2003, 06:47 AM
Hello.
Sorry for this another non-OGL question (but it happens when linking OGL application http://www.opengl.org/discussion_boards/ubb/smile.gif ). I don't know why am I getting so much bugs when using the compiler. I've included everything, set include guards and i still get some annoying bugs all the time. So... Could anyone told me what THAT means :

LIBCD.lib(wincrt0.obj) : error LNK2001: unresolved external symbol _WinMain@16

Thanks for your help
I hope I'll run my program some day...

mikael_aronsson
03-09-2003, 06:51 AM
Hi !

You have compiled your application as a windows application, that requires that you have a WinMain() function (maybe you have a main function ?), the alternative is to mark your application as a console application, in that case you need a main() function instead.

Mikael

03-09-2003, 07:27 AM
Hello

Thanks for your reply. Unfortunately my application is windows application and I use a WinMain() function. Aarghh...
I have no idea why my project doesn't work. All the time I get tons of bugs. I think I can't manage to gather the source files and the headers together properly. There must be something important I don't know. And I don't think that I'll find out what is wrong in the nearest month http://www.opengl.org/discussion_boards/ubb/frown.gif.
But...
Could you do me a favour, Mikael? I'll send you my workspace by e-mail and you just take a look on it. I beg you! I please you! I cry! It's just a tiny little application. Don't let it die!
My e-mail is : proton2000@poczta.fm
It would be fantastic if you help me. PLEASE!!!

Thanks in advance

[---]