PDA

View Full Version : broken libglut?



gunslinger
02-25-2004, 11:26 PM
hi all,

first thing i have to say: sorry if i am OT, but i am growing a bit frustrated and I do need a bit of help :|

i have installed the NVidia SDK on my linux machine, and achived full success...

now i wanted to compile also che cg examples, and guess what? My pc keeps telling me:

g++ CA_GameOfLife.o GL_GameOfLife.o ppm.o -o GL_GameOfLife -lz -L../shared -lnvs
dk -L../../../../LIBS/lib -lnvparse -lglut -lGLU -lGL
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XGetExtensionVersion'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XFreeDeviceList'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XQueryDeviceState'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XListInputDevices'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XFreeDeviceState'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XOpenDevice'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XmuLookupStandardColormap'
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/../../../libglut.so: undefined referenc
e to `XSelectExtensionEvent'
collect2: ld returned 1 exit status
make[1]: *** [GL_GameOfLife] Error 1
make[1]: Leaving directory `/home/enrico/exrstuff/NVSDK/DEMOS/OpenGL/src/GL_Game
OfLife'
make[1]: Entering directory `/home/enrico/exrstuff/NVSDK/DEMOS/OpenGL/src/Proced
uralTexturePhysics'
g++ CA_Water.o ppm.o ProceduralTexturePhysics.o -o ProceduralTexturePhysics -lz
-L../shared -lnvsdk -L../../../../LIBS/lib -lnvpng -lnvutil -lnvparse -lglut -lG
LU -lGL
make[1]: *** Deleting file `ProceduralTexturePhysics'
make[1]: *** [ProceduralTexturePhysics] Interrupt
make: *** [all] Interrupt

I tried to re-link my libglut.so, but still nothing to do... now i am stuck. Anyone had the same problem? I am using Nvidia drivers on a redhat 9 linux. Any help will be kindly appreciated.

mikael_aronsson
02-26-2004, 12:01 AM
Have you included the X and glx libraries when you link the app ?

Mikael


[This message has been edited by mikael_aronsson (edited 02-26-2004).]