PDA

View Full Version : HELP does any one know how to set up Windows ME to run openGL



09-19-2002, 04:09 AM
i can run pre compiled applications frrom a cd that i have but i can't compile. im using visual c++ 6.0 and windows ME. What files need to go where?
thanks

John Jenkins
09-19-2002, 04:15 AM
I can't fix your problem but I can tell you that you are better off getting rid of ME and going to XP.

V-man
09-19-2002, 04:53 AM
Copy the files to your hard drive somewhere. Obviously you won t be able to compile from a CD since you cant write files to a ROM disk!

Be sure to install the latest drivers for your video card. that should be enough.

V-man

Deiussum
09-19-2002, 04:59 AM
What kind of errors do you get with the compile? Does the CD come with project files to open, or are you just creating your own project and adding source files?

If you are getting linker errors, it's likely that you haven't added the appropriate libraries to the project.

If the apps use glut and you haven't downloaded the glut headers and libraries, that might also be a problem.

09-19-2002, 05:59 AM
Originally posted by Deiussum:
What kind of errors do you get with the compile? Does the CD come with project files to open, or are you just creating your own project and adding source files?

If you are getting linker errors, it's likely that you haven't added the appropriate libraries to the project.

If the apps use glut and you haven't downloaded the glut headers and libraries, that might also be a problem.

the only error that i get says something like " unable to execute c1.exe " or something similar to that

Deiussum
09-19-2002, 06:37 AM
Did you copy the files to the hard drive as V-man said? Do you get that error when trying to create your own projects? cl.exe is the compiler for VC++ so if it can't execute that, it would seem to indicate that something is messed up with your VC++ install.

tinak
09-19-2002, 07:37 AM
I'm using ME with VC++. Here's what I did when I reinstalled recently.

1. Install VC++ - it will automatically set up LIB and INCLUDE directories for use in projects. It will also include GL and GLU libraries and include files in the INCLUDE/GL and LIB directories. Set up a simple Windows application and make sure it compiles/builds and executes with no problem. If there is a problem, your C++ installation must have gone wrong somewhere.

2. To use GLUT or GLUI save the LIB file to the LIB directory and the H file to the INCLUDE/GL directory. Place the GLUT32.DLL file into either the WINDOWS\SYSTEM or WINDOWS\SYSTEM32 directory. They both are checked when searching for required DLLs.

3. Set up a simple GL or GLUT program to test that it will work. Don't forget to either add the lib references in the project settings (although some of my glut programs don't seem to require it) or set up the PRAGMA settings to do this for you.

These steps should have you up and running in no time..

Tina

09-19-2002, 08:49 AM
try linux

*Aaron*
09-19-2002, 09:48 AM
I can't fix your problem but I can tell you that you are better off getting rid of ME and going to XP. This is not an operating system issue.


try linux
<sarcasm> Oh, yeah, installing and using Linux is _much_ easier that Windows. Especially for a beginner who probably has no experience with Unix. </sarcasm>

This is not a problem with OpenGL; you obviously don't have your compiler set up correctly. Do what Tina says. Then try to compile a "Hello World" program before you jump into OpenGL.