PDA

View Full Version : Polygon Smoothing



12-03-2003, 08:13 AM
When I enable polygon smoothing in my scene, with GL_POLYGON_SMOOTH_HINT set to GL_NICEST, the framerate goes below 1 fps (before this operation, it was over 70). What could be the problem?
Does anybody know whether GeForce 4 MX 440 has hardware support for GL_POLYGON_SMOOTH, or where the OpenGL NVidia driver is located? (In my sistem, C:\Windows\System32\OpenGL32.dll says it is manufactured by Microsoft; however, on the opengl.org site I was said that each chipset company delivers its own opengl driver, but on the NVidia site I couldn't found any)

virtualchetan
12-03-2003, 11:20 AM
I had a similar problem although I work on a Linux machine.

If u r using nVidia card, dont enable the software anti-aliasing .... polygon smoothing.
But, set _GL_FSAA_MODE to 4, which will enable
hardare anti-aliasing using 4 pixels from 4 corners of a given pixel.

- Chetan

12-04-2003, 08:25 AM
But how can I set the GL_FSAA_MODE parameter? (Which function do I call, which takes this constant as parameter?)

-Stefan

Tzupy
12-04-2003, 01:36 PM
Hi,
If you can only use software rendering, then polygon antialiasing using alpha blending is very slow and also inaccurate. You could try to install the Softquadro4 to tweak your drivers and have a 'SoftQuadro4' 550 XGL. If you only want the standard FSAA of 4x (or 8x with Rivatuner), the speed drop won't be disastrous, but the quality is lower than the blending antialiasing on a Quadro4.