PDA

View Full Version : Please help!! :)



roberts
03-07-2001, 12:09 PM
hi all!
Question 1. I have to include all my libraries ie.opengl32.lib glut32.lib glu32.lib into Visual C++ 6 'Project/Settings/Link/object/ library modules' - every time I want to compile a program! http://www.opengl.org/discussion_boards/ubb/frown.gif Previously I didn't have this problem! How can I do this in such a way that once I include those libraries I won't have to do it again any more?????
Question2. Do I need any other libraries or utilities to run my OpenGL programs. Are those 3 above-mentioned files enough? or I need somthing alse?
Thank you very much for any help!!!

Deiussum
03-07-2001, 12:44 PM
Every time you compile, or every time you create a new project? Have you changed your glut.h recently? Do you use glut? glut.h has some precompiler pragmas that will cause those libraries to be linked in w/o having to add them to the project.

dpgraves
03-07-2001, 12:47 PM
Are you saving the workspace afterwards? It should be keeping those libraries in the list. Its a strange problem. My suggestion is to update to MSVC Service Pack 4 if you haven't done so already, or reinstall VC++.

roberts
03-09-2001, 04:29 PM
Thanks for Replay!!
Yes I have the same problem even after reinstalling Visual C++. The problem occurs when I create workspace!! Every time I have to go to Project settings and add those libraries OpenGL is using.

Deiussum
03-09-2001, 08:47 PM
That's to be expected. When you add those projects, you are adding them to the CURRENT project, not EVERY project yet to come. If the compiler linked in every available library for every project, you'd end up with a whole lot of libraries linked into your project that would be doing nothing but taking up space. If you save the project after adding those in, you shouldn't have to add them in again for THAT project (so long as you remember to add the libraries to both the debug and release configs), but you will have to add them again for any NEW projects.