PDA

View Full Version : glut on VC++5?



duke
03-01-2001, 01:41 PM
Hello all

I tried to use the precompiled glut32.dll and glut32.lib to compile some OpenGL programs but they do not seem to work. Then I tried to compile but the computer crashed! What am I doing wrong? What should I go to get glut working?
Thanks a lot for any suggestion you can give me!

mango
03-01-2001, 04:04 PM
Is it not possible to update VC++ 5 so it understands VC++ 6 libraries?
You should not have any problem to build from the sources: http://www.xmission.com/~nate/glut.html

Bahamut_france
03-02-2001, 12:41 AM
I tried to use the precompiled glut32.dll and glut32.lib to compile some OpenGL programs but they do not seem to work. Then I tried to compile but the computer crashed! What am I doing wrong? What should I go to get glut working?
Thanks a lot for any suggestion you can give me! [/B][/QUOTE

The first time, Visual C++ must be configured correctly. You must load in options the librairie glut32.lib and opengl.lib. Then, the headers files : .h
The glut32.dll must be placed in : windows\system\ (it is very important)
In Compilation Option (in LINK), it is necessary to add librairies used.
Then, normally it's working...
If the imports are good! the compilation is working....
If the compil is ok and the linking is failing.... it is options of linking (often).
(excuse me for this bad english because i'm french.
For beginning, write a very very smal programm ,to try glut.
If you problems after that, i can send you a documentation .... bye!

zed
03-02-2001, 01:06 AM
to get glut to work for vc u need to download the librarys for gluts source and recompile them for vc5 and use the new lib's

duke
03-02-2001, 06:57 AM
Hi again

I tried to compile form the sources but when I open the VC++ workspace, it says that "the proyect does not contain any configuration whose platform is supported in this version of Developer Studio. You will need to create new supported configuration..." etc. The I press Ok and try to compile but the computer crashes with the nice blue screen and it does not finish creating the DLL.
How can I fix that? Thx!

Tim Stirling
03-03-2001, 08:56 AM
I had a similar problem trying to use glut with vc5. I tried to recomplie but I didn't know much aboutt c++ or VC++ and so I gave up. I then downloaded the libary for vc5 which works OK but I need to find the older version of the dll as many functions that i tried to use or were used by demos didn't exist or work.

03-04-2001, 07:34 PM
When i compile opengl programs that use textires i get a link error with 4.0 is ther anyway i can maeke 4.0 use 6.0 files?