PDA

View Full Version : Fog question



goater
07-18-2001, 08:09 AM
I wonder if it is possible to use fog on a single polygon? I have a polygon that i use as a ground, but when trying to use fog on it, the fog is "constant". I guess that is due to the fact that it's just one single polygon?

Does someone now if it's possible to make fog that gets denser with the distance, on a single polygon?

Deiussum
07-18-2001, 09:31 AM
I believe different implemenations handle fog a bit differently. I believe I saw Matt post somewhere that GeForce class cards will use per-pixel fogging calculations. (If you don't know him, Matt works at nVidia writing OpenGL drivers.) You might want to try glHint(GL_FOG_HINT, GL_NICEST) to see if that gives you the results you want.

goater
07-18-2001, 09:41 AM
Thanks Deiussum...
..but I'm afraid I've already tried that.
I guess I'm into an unsolvable problem(?)...
Even if I try GL_NICEST it doesn't work. I guess the 3D video card is to weak?

goater
07-18-2001, 09:44 AM
strange, but I tried with a geforce2, and still the GL_NICEST doesn't work.
GL_EXP and GL_EXP2 works, but not GL_LINEAR.
without geforce none of it works...

Suggestions?

07-18-2001, 12:25 PM
I think that you should try to play around with the fog parameters to get greater difference. NVidia has some extension that gives you greater control on how the the fog is calculated. (GL_NV_fog_distance ?)

goater
07-18-2001, 10:06 PM
ok...but that will do the stuff for my geforce2 app but not for the other one, right? Coz it's without geforce2 that I'd like it to work http://www.opengl.org/discussion_boards/ubb/frown.gif
I guess one solution would be to use more polygons on the ground, to make the fog work, but that's kinda what I don't want http://www.opengl.org/discussion_boards/ubb/smile.gif
per pixel fog...could it work, and how to use it?

Thanks folks for all your contribution