PDA

View Full Version : OpenGL 1.2 or higher



HellRaiZer
12-24-2001, 12:41 PM
Hello.
Is there anyone who can tell me if OpenGL version has something to do with display drivers only. I know OpenGL 1.1 was included and distributed with Win95 or NT.
Can i upgrade my OpenGL version to 1.2 without changing my graphics card (Riva 128)? Is it included in WinME or somewhere else? Can i add multitexture support without having OGL 1.2 or higher? I know MESA drivers do this but they make my system very slow.
Also if anyone know where i can find Riva 128/ZX latest drivers (nVidia doesn't support it anymore).

Please reply.
Thanks in advance.

HellRaiZer

zed
12-24-2001, 12:59 PM
no more drivers for the riva128
even if u had opengl32.dll (opengl1.3) it would just be as slow a MESA the reason being your card (riva128) does NOT support multitexture thus it HAS to be done in software (newer drivers cant help the hardware)

i have a similar problem with my tnt2 it cant do dot3 mapping in hardware thus when i try to do it with my nvidia drivers (opengl1.3) it will be done in software ie 1 polygon == 1fps the only improment is a better card