PDA

View Full Version : Why the ***k ?



wXm
05-31-2001, 06:38 AM
Hi there learning openGL in w2k and VC++.

But the problem is when i compiled the code, it doesnt work if the computer running it doesnt have VC installed.. why ? and how do I fix it ?

It works just fine for me but I have VC installed.. doh..

Think that I need to link or include something, please some one help me http://www.opengl.org/discussion_boards/ubb/smile.gif..

Deiussum
05-31-2001, 09:09 AM
Are you using MFC? If so, you'll need the MFC dlls on the target machine, or you'll need to statically link MFC into the project. (It's the first tab on the project settings that lets you do that.)

I've also noticed that if you use some STL stuff, some of the target Win2k machines haven't had the latest runtime libraries (msvcp60.dll).

Use the Dependency Walker that comes with VC++ to see what DLLs your app uses and see which ones are missing on your target machines.

Korval
05-31-2001, 10:12 AM
Also, in addition, you should only be trying to distribute release builds. Machines without VC++ will not have the debug MFC dlls.

wXm
05-31-2001, 11:16 AM
Thanks alot. I'll try that..