PDA

View Full Version : I wonder a simple thing ...



antspider
12-10-2005, 03:15 AM
My system is Linux Fedora core 3 complete installation, I wonder that the openGL library is installed in my OS automatically, or I should install it additionally, Thanks a lot!

dmy
12-10-2005, 06:21 AM
probably yes... open a terminal and try:
rpm -qa | grep -i mesa

you will see wich mesa (-> opengl implementation for linux) libraries you have on your system.

antspider
12-11-2005, 05:00 PM
It is very kind of you, thanks!
I typed the string, shows as following:
xorg-x11-Mesa-libGL-6.8.1-12.FC3.21
xorg-x11-Mesa-libGLU-6.8.1-12.FC3.21
Is that means openGL installed in my system, and vesion?

Adam Luchjenbroers
12-14-2005, 03:31 PM
Definitely means you've got Mesa installed (Mesa version 6.8.1), not sure what OpenGL version that is (either 1.4 or 2.0, probably).

Depending on what you're doing, you might want to find out if you're using indirect or direct rendering (glxinfo should tell you this, among other things). Indirect rendering means you're using Mesa's software OpenGL implementation to do the rendering (this will be slow). Direct rendering means you're using your hardware for rendering (you need to install and setup the appropriate drivers to have this working).

antspider
12-26-2005, 12:08 AM
server glx version string: 1.2
client glx version string: 1.4
OpenGL version string: 1.3 Mesa 6.1
glu version: 1.3

But I edit an example and compile, so many undefined references...

What happened?

Thanks all!

antspider
12-26-2005, 12:08 AM
server glx version string: 1.2
client glx version string: 1.4
OpenGL version string: 1.3 Mesa 6.1
glu version: 1.3

But I edit an example and compile, so many undefined references...

What happened?

Thanks all!

H.Stony
12-26-2005, 01:03 AM
link against the libraries.

something like that: gcc main.c -o test -lopengl.....

antspider
12-28-2005, 01:36 AM
I compile my opengl c file:firstGraph.c like this:
gcc firstGraph.c -lglut -ffast-math -lMesaGLU -lMesaGL -lm -L/usr/X11/lib \
-L/usr/X11R6/lib -lX11 -lXext -lXmu -lXt -lXi -lSM -lICE -o firstGraph

but failed, it shows: cannot find -lMesaGLU. my Mesa have installed, and I don't know why.