PDA

View Full Version : Blending problem



MrShoe
10-03-2001, 07:10 PM
I have written a program where the user can walk around a room with a nice particle effetc in the middle... the problem is that this particle effect can be seen even though when you go behind a wall... this is because it is alpha blended... i can sorta fix this by frawing it first, but then you cant see it because the walls and other objects draw over it, how can i fix this??

DFrey
10-03-2001, 08:00 PM
You need to disable z writes when drawing the sorted alpha blended polygons, but leave z testing enabled.

MrShoe
10-03-2001, 09:42 PM
Ummm, leaving z testing on as in glEnable(GL_DEPTH_TEST)??
Also, how do i disable z writes??

Bob
10-04-2001, 12:08 AM
glDepthMask(GL_FALSE), and GL_TRUE to turn it on again.