PDA

View Full Version : Beginer, Please help



Realmsman
12-14-2003, 09:25 PM
I am just starting openGL.
My problem is that I am geting this warning:
GLUT: Warning in C:<my_personal_path> The following is a new check for GLUT 3.0; update your code.
I want to get rid of this warning. Where can I get an update? And what exactly needs to be updated?

I don't know if it makes a difference, but I am using the introductory version of MS VC++ and running XP.
Thanx

Leyder Dylan
12-15-2003, 01:02 AM
Glut 3.0 is outdated. I think that now, there's a 7.2 version.

Am I right ?

Overmind
12-15-2003, 05:52 AM
Sounds like a deprecation warning. You are propably using some function of glut that is only there to ensure backwards compatibility to an old version of glut, but it should not be used anymore with the new version. You have to update your own code so you don't use the deprecated function but instead the new version.

nexusone
12-15-2003, 06:59 PM
I have a link on my website for windows glut, currently glut is at 3.7.
www.angelfire.com/linux/nexusone/ (http://www.angelfire.com/linux/nexusone/)



Originally posted by Realmsman:
I am just starting openGL.
My problem is that I am geting this warning:
GLUT: Warning in C:<my_personal_path> The following is a new check for GLUT 3.0; update your code.
I want to get rid of this warning. Where can I get an update? And what exactly needs to be updated?

I don't know if it makes a difference, but I am using the introductory version of MS VC++ and running XP.
Thanx

Realmsman
12-17-2003, 06:48 PM
Thanx all