PDA

View Full Version : Compatability Issue



Tomy
03-31-2005, 05:24 AM
Hi,

I am using a GeForce 6800 Ultra card. I made a program that uses a fragment shader and 3d textures. I know these two features are not supported by many of the older NV cards. I need to understand, where are these features implemented? Is it in the chipset or is it the driver or the video card model? Plus, what would be the minimum requirements of the video card I should use, a version? Would my program run on a non-NVidia card?

Thanks :)

Jan
03-31-2005, 09:23 AM
3D Textures are supported since Geforce 3 (donīt know the name of ATIs equivalent, Radeon 8xxx i assume). 3D textures are not a big problem, as long as you donīt want to support very old hardware.

"a fragment shader" will only be supported, if you use ARB_fragment_program or glSlang. NV_fragment_program is naturally only supported on NV cards (Gf 5+). The other two are supported on Gf 5+ and on Radeon 9500+ (all DX 9 hardware).

The moment you use fragment programs, the amount of hardware, which it works on, gets pretty small...

Jan.

Tomy
04-01-2005, 10:56 PM
Thank you Jan for your valueble post :)