PDA

View Full Version : Flickering OGL



M/\dm/\n
04-02-2003, 04:02 AM
I'm using glut runing at WINXPPRO & at fullscreen mode windows flickers a lot. I have GF2GTS and lastest det's, unfortunately ther's no refresh override function.

nexusone
04-02-2003, 05:19 AM
Are you using double buffers?



Originally posted by M/\dm/\n:
I'm using glut runing at WINXPPRO & at fullscreen mode windows flickers a lot. I have GF2GTS and lastest det's, unfortunately ther's no refresh override function.

M/\dm/\n
04-02-2003, 05:41 AM
Yeap, for sure. Wasn't ther somthing like 800x600@85 in glut?

shinpaughp
04-02-2003, 11:35 AM
Do you have vsync on or off? If it is off, turn it back on and you shouldn't see any flicker. If it is on, I got no clue. http://www.opengl.org/discussion_boards/ubb/biggrin.gif

HalcyonBlaze
04-03-2003, 06:52 AM
You aren't by anychance swapping the buffers twice accidentally per frame are you? I had a problem with that once that resulted in masive flickering!

- Halcyon

Raduprv
04-04-2003, 01:10 PM
Do you have the lights on or off?
Also, it might be a Z buffer problem. Can you paste some code here? (your main loop)

M/\dm/\n
04-06-2003, 11:53 PM
I have ligting based on Cg, so it shouldn't be the problem. Well everything is OK in windowed mode, something must be wrong with glutgamemode http://www.opengl.org/discussion_boards/ubb/frown.gif

hcdlt
04-08-2003, 03:46 AM
there's a problem with winxp every gamer knows about: the "60Hz bug". Just search the internet and you will find a couple of solutions.

M/\dm/\n
04-08-2003, 04:19 AM
I knew DX had this bug, but everything should be ok with OGL?