PDA

View Full Version : a question about OpenGL versions...



Frostie
03-07-2007, 01:17 AM
Maybe my question is a little bit stupid.
I searched information about vertex arrays buffers and found out that it is supported since version 1.5.
What I don't know is how to get 1.5.
I don't think that I go to website abc and download it as it depends on my hardware.
My hardware is a notebook with a mobile ATI FireGL chip (I don't know the exact type now).
I read that it should be capable of OpenGL 1.5 (maybe higher).

So to me it seems that I have to hope that ATI/AMD releases a driver that supports the right OpenGL version. But still I need to get the libraries, header etc...

Can anybody explain the options and what I could do or have to do to be able to use vba's.

Zengar
03-07-2007, 01:52 AM
All moder cards support even 2.0, but you have to use the extension mechanism to query the function pointers, due to issues with the windows OpenGL implementation. This is all in the wiki, you can also consider to use libraries like GLEW.

P.S. This question is asked every three day an average. You can't imagine how annoying this is ;-), but I can't really blame you.

Frostie
03-07-2007, 05:51 AM
Thank you for the hint.

Believe it or not - I never looked into the wiki, I didn't even know it was there :-)

I will study it now...

Kor
03-07-2007, 07:40 AM
to have informations about your graphic card, try glview : http://www.realtech-vr.com/glview/download.html