PDA

View Full Version : Mipmaps automatically generated by GL_SGIS_generate_mipmap are corrupted.



VuurSnikkel
03-06-2004, 08:31 AM
Hello there...


I'm currently having problems with using wgl_arb_render_texture in conjunction with GL_SGIS_generate_mipmap (I want GL_SGIS_generate_mipmap to automatically create mipmaps whenever I have rendered something to my texture using wgl_arb_render_texture). As far as I know, I've set up everything correctly (see "P.S." for more information); I can render to texture, use the texture in both of my rendering windows and GL_SGIS_generate_mipmap also automatically seems to be generating mipmaps, but something is wrong with one of the smaller ("higher") generated mipmap levels (it looks corrupted).

If I move the right slider (Texture Scale) of my program ( http://www.sickcrew.com/~inforum/vuursnikkel/mme/SpotNice.zip ) approximately between 0.05 and 0.10, then the main rendering window shows the corrupted mipmap (at least on my system; WinXP, Radeon 9800 Pro, latest Catalyst drivers (04.2)). Changing the other sliders clearly shows that the mipmaps are automatically regenerated, but the corrupted mipmap level still remains corrupted, despite the fact that it's changing.

Someone pointed out to me that the .exe crashed with an access violation, so I recompiled it and added the necessary DLL's (glu32.dll and glut32.dll) and re-upped it. If someone still has problems running it, here's a series of screenshots illustrating the problem http://www.sickcrew.com/~inforum/vuursnikkel/mme/mipmaperror1.jpg through .../mipmaperror6.jpg.

So it seems like the GL_SGIS_generate_mipmap extension is somehow doing it's job (hence the fact that the mipmaps are updated), but not without a flaw (one of the mipmap levels is corrupted).

If someone recognizes this problem and/or has any idea how to solve it, I would be really grateful. Thanks in advance.


Greetings,

(Sn)Ik.


P.S.

More information about what I'm doing and how I have setup OpenGL can be found in another thread: http://www.opengl.org/discussion_boards/ubb/Forum2/HTML/015655.html ("Passing texture data to glTexImage2D.")

[This message has been edited by VuurSnikkel (edited 03-06-2004).]