PDA

View Full Version : Windows XP Init Failes



Micke
04-28-2002, 12:40 AM
Ive been coding in GL for a couple of years now.

All my programs works fine in Windows 95,98 and 2000.
But when Im trying them on XP the program failes with the following message:
Failed to init error adress 0xc0000005.
Doing some research I thinkits a accsess denied but WHY?

Need help FAST.
/Micke

CGameProgrammer
04-28-2002, 03:59 PM
Are you sure you have working OpenGL drivers? Do other programs work with OpenGL on that system?

04-28-2002, 04:31 PM
Make sure you download and install the drivers from NVidia.com.

Microsoft (suprisingly enough) does not actually want you to use OpenGL, it wants you to use Direct3D - so it leaves support for OpenGL out, you have to install it with newer drivers.

Deiussum
04-29-2002, 05:42 AM
Have you tried stepping through your app to find exactly where it's crashing? It's possible that the crash isn't OpenGL related at all. It's possible the other versions of windows were more forgiving of you improperly accessing memory somewhere.

CGameProgrammer
04-29-2002, 11:22 AM
That's a good point, it might not be an OpenGL error. But I'd don't think WinXP is less forgiving than Win2000. Still, memory errors do have the habit of lurking unseen for a while.

Micke
04-30-2002, 04:28 AM
I have the latest drivers and other OpenGL programs works fine.
My init routines is taken straight from the OpenGL superbible 2nd edition
so they should be okay.

Since im not using XP myself its hard to find the error.
Well , I guess I must dump all my **** to my brothers computer and compile
the whole thing using XP.

I hoped that someone could have encountered the same problem or am I
the only "lucky" bastard http://www.opengl.org/discussion_boards/ubb/frown.gif