PDA

View Full Version : Smooth Graphics



Zeus_666
06-20-2001, 06:27 AM
Hi,
Another question i have is that i have designed a map with a rectangle for the ground and rectangles as the walls. I have noticed that unless you look the wall stright on then where the floor and wall meet looks all jaggered, is there any way to get rid of this.

Thanks

zed
06-20-2001, 12:19 PM
the dreaded jaggies.
sounds like a lack of depth buffer precision. increase the near z buffers value

Zeus_666
06-21-2001, 02:50 AM
It happens when things are looked at on an angle, increasing the z buffer value did not help. Thanks anyway.

Paul

tdavie
06-21-2001, 04:34 AM
Jaggies are there simply because a diagonal line is a very hard thing to draw with a set of horizontaly and verticaly aligned dots (pixels on your monitor). There is only one real solution to this problem: Antialiasing, what this does is fills in half tones of the various colours along the edge of the lines so that they appear smoother and seem to blend into the next colour slightly. There are two ways of doing this:
1. Use OpenGLs antialiasing - this isn't very good, and you probably won't be happy with the results, however it does work on almost all computers.
2. If you have a modern graphics card, you can turn full screen antialiasing on, this is usualy very good quality, but only modern graphics cards have the power to do it.

Zeus_666
06-21-2001, 05:00 AM
Hi,
Turned antialaising to 4x but this did not make any noticeable difference, i have a Geforce2 MX 32MB

How do games like half-life get round the problem, elite force...

[This message has been edited by Zeus_666 (edited 06-21-2001).]

harsman
06-21-2001, 06:12 AM
Try just increasing the size/resolution of the window you're rendering to. If it isn't aliasing but depthbuffer precision (Does it flicker when you change view/rotate, if it does it's probably the depth buffer) you should bring the near and far planes closer together. Push the near plane out (put a larger zNear in gluLookat) and bring the far plane in.

06-21-2001, 11:25 AM
Originally posted by Zeus_666:
Hi,
Turned antialaising to 4x but this did not make any noticeable difference, i have a Geforce2 MX 32MB

How do games like half-life get round the problem, elite force...

[This message has been edited by Zeus_666 (edited 06-21-2001).]


How do u turn antialaising on in OpenGL?

Zeus_666
06-21-2001, 10:12 PM
I turned it on throught my desktop properties, unsure on how to do it in openGL

Fastian
06-22-2001, 01:02 AM
Originally posted by Zeus_666:
I turned it on throught my desktop properties, unsure on how to do it in openGL

for antialiasing in OpenGL simply use

glEnable(GL_LINE_SMOOTH);

j
06-22-2001, 05:40 AM
Uhhh, that's a bit different than the anti-aliasing he wants. You can enable FSAA through the control panel for your video card, if it supports it. I think the ARB_multisample extension is what you are supposed to use with OpenGL, but I believe it is currently only supported by the GeForce3, and maybe the Voodoo5.

j