PDA

View Full Version : Please help!



tenasken
04-05-2002, 02:16 PM
Hi,
I'm a newbie to OpenGL, but I have some experience with 2D graphics using Linux/SDL. I have a question regarding books about OpenGL. At the SGI website they say that the current release of OpenGL is 1.3. And now I see that there is going to be a release of OpenGL 2.0. It seems that I can only find books on programming OpenGL 1.2. Is there an official OpenGL Programming Guide for the version 1.3? The book on 1.2, although it is the official programming guide, was published in 1999. Is this book out-dated? Should I perhaps keep looking for a book on the 1.3? Or will I be studying out-dated material considering that OpenGL is going into version 2.0?
Please help!

zeckensack
04-05-2002, 02:28 PM
Basic operation hasn't changed much over the years. The only stuff that happened was the promotion of several extensions into the core spec, eg multitexture and texture environment stuff.

So I'd say, no, there's no immediate need for updated books. But do make sure to get the 1.3 spec and take a look at the extension registry (http://oss.sgi.com/projects/ogl-sample/registry/) .

As for OpenGL2, AFAIK it will still keep the same basic principles, plus some very nice flexibility enhancements. This is looking like a painless migration. For a final verdict, we'll have to wait until the spec is finalized and the implementations become available.

zed
04-06-2002, 01:51 PM
get the red book (covers opengl 1.2) the difference from 1.2->1.3 is very small.
perhaps youre thinking like in d3d with a new version eg d3d8 makes books about d3d7 practically worthless, with opengl this is not the case because of the backwards compatabilty. (though when opengl2.0 comes out this may change but thats at least a year away so dont delay getting a book waiting for it)

tenasken
04-06-2002, 10:45 PM
Nice! Thanks for the help; indeed I will not waste another second!

int awYeah(uh->huh*2){
return lmao;
}