PDA

View Full Version : OpenGL and glvertex3fv cause crash?



Phobeus
06-26-2002, 10:28 AM
Hi,

i am currently hunting a strange bug. I create a bigger arraym with several points and pushing them with glvertex3f on the screen. Everything seems to work quite fine at the first moment (the model is a wheel), but during rotation, sometimes, it looks like some points are moving out fastly for a few moments and then suddenly back.

The speed drops for a moment and then everthing is running fine 3 or 4 rotations and then suddently the pc hangs. I checked out for a read over the model points, but everything seems fine. Also sometimes he hangs a few second after start, then only after some minutes, no change to reconstruct the problem.

Only a shoot in the corn, I guess, but anyone a good idea?

Ceya,
Phobeus

Gavin
06-26-2002, 12:54 PM
Memory problem? How are you passing values to glvertex? Out of bounds array?
NaN?

Phobeus
06-26-2002, 09:23 PM
Yes, that's what I guessed, but the information are correct no read over the borders, even if I draw only half of the points. The problem only happens when I use the wheel, all other even complex objects seems to work without this problem.

But it can't possible that a model is somekind of damged, can it? It really strange, never had such problems before. :-/

06-27-2002, 08:28 AM
Are you using glPushMatrix/glPopMatrix? If so, make sure the number of calls is equal. Are you sure all your glBegin()'s have a matched glEnd()?

BlackJack
06-27-2002, 08:30 AM
myserious...... well, i personally also guess that any of your vertices are damaged if it's really only a problem with one single object =/...

BlackJack