PDA

View Full Version : GLsdk



xoquoxxotil
12-19-2006, 06:14 PM
Is there any new SDK that can support the OpenGL 1.6 or higher version?

Zengar
12-20-2006, 01:01 AM
There is no OpenGL SDK at all yet... Hovewer, it was promised that we get one soon. What do you mean by SDK anyway, do you need only libraries or something else?

Overmind
12-20-2006, 02:14 AM
Btw. there is no OpenGL 1.6. The version number jumped directly from 1.5 to 2.0. The current version is 2.1.

Zengar
12-20-2006, 04:17 AM
Also true :-)

k_szczech
12-20-2006, 04:38 AM
Ok, previous replies explained, that there is no SDK (yet) and there is OpenGL 1.0-1.5 and 2.0-2.1. But I think the main (although hidden) question needs to be answered: If you want to use latest OpenGL functionality, then you should use an extension loading library like GLEW. Or you could just load extensions yourself if you got too much time to spend :)

xoquoxxotil
12-21-2006, 06:40 PM
:-( Actually there is always something wrong in the glew,or how i can i use glew??

ZbuffeR
12-21-2006, 11:48 PM
GLEW is fine here.
If you use it statically, you just need to add glew.c in your C project, and need to define GLEW_STATIC, as explained in the doc http://glew.sourceforge.net/install.html :

#define GLEW_STATIC 1
#include <glew.h>

... then your gl/glu prog here.

What is you problem exactly ? Did you look at the GLEW mailing list archives ?